Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SG300 Routing Issues - Need Help

Been having an issue for weeks where one vlan has internet access but the others do not and I have not been able to solve it. Here is the situation (see attached graphic for info).

I have the SG300 -10 in layer 3 mode. I have six vlan aware wireless access points on ports 1-6 (trunks) respectively. Each WAP has two ssid with their own tagged vlan.

Port 8 (general) is a PC I use for testing.

Port 10 is an access port on vlan 30 that connects to my router for internet traffic.

 

Everything works great between the vlans and dhcp is setup properly and working for vlans 10-30. 

Vlan 100- Managment Vlan

Vlan 30- everything works great. I can ping external IPs and names are resolved correctly and internet access is fine. 

Vlan 20 and 10- Internal routing works fine, external routing dies. Ping 8.8.8.8 fails outright. Ping for google.com properly pulls the IP from DNS then dies. Tracert shows

1  192.168.10.1 (switch interface)
 2  192.168.30.1 (router)
 3  request timed out.....etc

 

I have static routes in the router setup (see graphic) and they appear to work fine internally for routing data to the switch.

In the switch I have a static route to forward any requests outside of the vlans to the router at 192.168.30.1.

0.0.0.0  0.0.0.0  192.168.30.1

 

I've tried so many things and can't get any internet access on any vlan except for vlan 30 which is the subnet the router is on. Config file attached. 

Please help! Thank you.

 

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

No,its not possible to do

No,its not possible to do routing for internet at SG300-10.you need to do required configuration on router.

6 REPLIES
Bronze

Hi,

Hi,

 

Configure the port GE10 as below:

 

interface gigabitethernet10
 switchport trunk allowed vlan add 10,20 
 switchport trunk native vlan 30 
New Member

Tried making those change but

Tried making that change but figured it would not work since the router I'm using is not vlan aware and likely would not pass tagged packets. Exhibits the exact same behavior whether a trunk or access port.

Bronze

In switch required

In switch required configuration is done.Now you need check with router configuration.Kindly share router model number.so that we move forward on this issue.

 

 

New Member

Thanks for the reply.The

Thanks for the reply.

The Router is SMCD3G-CCR

Its a comcast router so I don't have access to all the settings. I can upgrade to a Netgear CG3000DCR which I've been told will give me more control over the settings like the ACL or I can use a spare Motorolla cable mode sb6121 but its not a router and I'm not sure if the Cisco SG300-10 can handle all routing tasks. 

Bronze

No,its not possible to do

No,its not possible to do routing for internet at SG300-10.you need to do required configuration on router.

New Member

The issue was the router. It

The issue was the router. It does not support NAT for internal networks on a different subnet. It routes LAN traffic correctly accoring to the static routes I setup for each vlan but NAT fails. The solution was to get a stand alone router that is VLAN aware and now everything is working perfectly. 

193
Views
0
Helpful
6
Replies
CreatePlease to create content