Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

sh vlan brief not showing correct vlan info

Hi,

I have a 3750G-24T connected to a C3550-48.

VLAN trunking has been setup on the 3550 switch, but on the 3750G, I cannot see the configured VLANs that the rest of our network sees. All I can see is the default vlan info. I have done this a gazillion times before, so I don't know what I have missed this time....

Here is the config:

c3750G

interface GigabitEthernet1/0/1

description Connected to *** port fa0/29 c3550

interface Vlan2

ip address 10.250.1.42 255.255.255.0

no ip route-cache

!

ip default-gateway 10.250.1.254

ip classless

ip route 0.0.0.0 0.0.0.0 10.250.1.254

C3550

description Connected to 3750-24G switch ***

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

interface Vlan1

no ip address

!

interface Vlan2

description backbone network

ip address 10.250.1.13 255.255.255.0

ip helper-address 10.250.1.50

no ip redirects

no ip route-cache cef

standby 5 ip 10.250.1.254

standby 5 preempt

!

interface Vlan3

no ip address

!

interface Vlan4

ip address 10.250.4.251 255.255.255.0

no ip redirects

standby 10 ip 10.250.4.254

standby 10 preempt

standby 10 authentication ***

!

interface Vlan10

ip address 10.250.2.254 255.255.255.0

!

interface Vlan11

no ip address

3 REPLIES
New Member

Re: sh vlan brief not showing correct vlan info

interface GigabitEthernet1/0/1 on the 3750 is not configured as a trunk.

If you want it to be a trunk, which I assume you do, try;

interface GigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

Hope this helps

Bronze

Re: sh vlan brief not showing correct vlan info

d-fillmore,

By default, aren't all ports set to dynamic desirable? And if so, wouldn't the 3750 negotiate a trunk with the other switch? Since the original poster didn't post that part of the config, I assumed it was left as default. If that's not the case, I apologize. BTW, I also like to force trunk ports to trunk and turn off all negotiation. It prevents weird things from happening. :)

To the original poster, verify that there is a trunk (I agree with d-fillmore; force it to trunk) and check your VTP mode, domain, and password on the 3750.

New Member

Re: sh vlan brief not showing correct vlan info

FYI - I have another setup which is pretty much identical, and I have only setup trunking on one switch and left the other end without trunking. The only difference is both of the switches are C3550-48's. These two connections have always worked fine.

Switch 1

interface FastEthernet0/1

description Uplink port to ** port fa0/47

switchport trunk encapsulation dot1q

switchport mode trunk

Switch 2

interface FastEthernet0/47

description Uplink to *** port fa0/1

switchport access vlan 21

no ip address

duplex full

speed 100

434
Views
0
Helpful
3
Replies
CreatePlease login to create content