Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

show cdp neighbor doesn't show up any neighbor

Hi,

I have one router C3925 which uses HWIC-4ESW module card to connect to two Gigabit port on 2960 SWs. The Router can ping two SWs, but no neighbor when issue "show cdp" command. However, 2 SW can see the router in "show cdp neighbor" command.

The Router has IOS "c3900-universalk9-mz.SPA.151-4.M2.bin" installed on it.

All connected ports are trunk.

Thanks to any advices

4 REPLIES
VIP Purple

show cdp neighbor doesn't show up any neighbor

Does "sh cdp interface" output of your 3900 router show the HWIC interfaces as CDP enable ?

Rasika

New Member

show cdp neighbor doesn't show up any neighbor

Can you please share the configuration of trunk ports at both end. Thanks

show cdp neighbor doesn't show up any neighbor

Hello, Can you check if 'no cdp enable' command applied on trunk interfaces of the router.

Regards,

Yaseen

New Member

show cdp neighbor doesn't show up any neighbor

Hi,

This is my configuration file

On Router

interface FastEthernet0/0/0

description " TO RP-Router-2 "

switchport mode trunk

no ip address

!

interface FastEthernet0/0/1

description " TO RP-Sw-1 "

switchport mode trunk

no ip address

!

interface FastEthernet0/0/2

description " TO RP-Sw-2 "

switchport mode trunk

no ip address

!

interface FastEthernet0/0/3

no ip address

!

On Switch

interface GigabitEthernet0/1

description " TO RP-Router-1 "

switchport mode trunk

switchport nonegotiate

!

interface GigabitEthernet0/2

description " TO RP-Router-2 "

switchport mode trunk

switchport nonegotiate

!

on my Router, CDP is enabled by default

RP-Router-1#show cdp interface

Embedded-Service-Engine0/0 is administratively down, line protocol is down

  Encapsulation ARPA

  Sending CDP packets every 60 seconds

  Holdtime is 180 seconds

GigabitEthernet0/0 is administratively down, line protocol is down

  Encapsulation ARPA

  Sending CDP packets every 60 seconds

  Holdtime is 180 seconds

GigabitEthernet0/1 is up, line protocol is up

  Encapsulation ARPA

  Sending CDP packets every 60 seconds

  Holdtime is 180 seconds

GigabitEthernet0/2 is up, line protocol is up

  Encapsulation ARPA

  Sending CDP packets every 60 seconds

  Holdtime is 180 seconds

FastEthernet0/0/0 is up, line protocol is up

  Encapsulation ARPA

  Sending CDP packets every 60 seconds

  Holdtime is 180 seconds

FastEthernet0/0/1 is up, line protocol is up

  Encapsulation ARPA

  Sending CDP packets every 60 seconds

  Holdtime is 180 seconds

FastEthernet0/0/2 is up, line protocol is up

  Encapsulation ARPA

  Sending CDP packets every 60 seconds

  Holdtime is 180 seconds

FastEthernet0/0/3 is down, line protocol is down

  Encapsulation ARPA

  Sending CDP packets every 60 seconds

  Holdtime is 180 seconds

717
Views
0
Helpful
4
Replies
CreatePlease to create content