Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Show policy-map in 4500+sup6 using per-port per-vlan qos

Hi guys.

We are using qos per-port per-vlan in all user ports of our Cat4510+sup6e boxes. By this way in each port we have attached two policy-maps for data vlan and voice vlan.

Well, we are trying to obtain per-port qos statistics using "show policy-map interface gigabitethernet x/y" command, but we obtain the same statistics in all ports (the same amount of matches for traffic classes in all ports). We thing chasis is showing us agregate o global statistics por each vlan.

Is there anyway to obtain real per-port, per-vlan statistics? is this a bug in 12.2(53)SG IOS version?

Thx.

Everyone's tags (5)
4 REPLIES
Hall of Fame Super Bronze

Re: Show policy-map in 4500+sup6 using per-port per-vlan qos

Please post the relevant portion from the config along with the show policy-map interface output.

New Member

Re: Show policy-map in 4500+sup6 using per-port per-vlan qos

Hi Edison, thanks for your response.

Take a look to this port config port. It is the same config for all ports. You can see we have attached a different policy-map for data vlan and voice vlan.

interface GigabitEthernet1/3
description Usuario
switchport access vlan 253
switchport mode access
switchport voice vlan 263
no logging event link-status
load-interval 60
no snmp trap link-status
spanning-tree portfast
spanning-tree bpduguard enable
vlan-range 253
   service-policy input pm_accesodat
vlan-range 263
   service-policy input pm_accesovoz

If you try "show policy-map interface GigabitEthernet x/y" you will see the same output for all ports (you can see it in attached files, we are thinking show policy-map command is showing aggregated statistics for both vlans), and we want to know if it´s possible to obtain this command output specifically for one port.

Hall of Fame Super Bronze

Re: Show policy-map in 4500+sup6 using per-port per-vlan qos

You are correct.

QoS is being applied to the Vlan and not the switchport so I recommend changing your configuration as followed:

Interface GigabitEthernet1/3
description Usuario
switchport access vlan 253
switchport mode access
switchport voice vlan 263
no logging event link-status
load-interval 60
no snmp trap link-status
spanning-tree portfast
spanning-tree bpduguard enable

service-policy input Voice_Data

class-map cm_acceso_voz

     match access-group name acl_acceso_voz

class-map cm_acceso_video

     match access-group name acl_acceso_video

class-map cm_acceso_senyalizacion

    match access-group name acl_acceso_senyalizacion

class-map cm_acceso_protocolos_control

   match access-group name acl_acceso_protocolos_control

class-map cm_acceso_aplicaciones_criticas

     match access-group name acl_acceso_aplicaciones_criticas

class-map cm_trusted_voz

    match ip dscp ef

class-map cm_trusted_senyalizacion

    match ip dscp cs3

policy-map Voice_Data

  class cm_acceso_voz

          police cir 192000 bps bc 6000 bytes

  class cm_acceso_video

          Set ip dscp af41

  class cm_acceso_senyalizacion

           Set ip dscp cs3
           police cir 1000000 bps, bc 31250 bytes

  class cm_acceso_protocolos_control

           Set ip dscp cs6

  class cm_acceso_aplicaciones_criticas

           Set  ip dscp af21

  class cm_trusted_voz

          police cir 192000 bps, bc 6000 bytes

  class cm_trusted_senyalizacion

          police cir 1000000 bps, bc 31250 bytes

  class class-default

          set ip dscp default

New Member

Re: Show policy-map in 4500+sup6 using per-port per-vlan qos

I have a couple dozen 4500's with Sup-6E's.  "show policy-map interface" counters are broken in the current code train your using.  Its still not fixed in 12.2(53)SG train.  It does not matter whether you use per-port or per port per vlan.  I have both QOS types configured and TAC confirmed the code problem with those counters.  Its doing exactly what you suspect showing aggregate counters for all ports.  Its ashame this is not fixed yet.

1661
Views
0
Helpful
4
Replies
CreatePlease to create content