Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

show policy-map interface question (QoS)

The counters are at 0 when I run show policy-map interface vlan 133 on a 3560 (desktop default). I have verified with Whireshark that the packets get rewritten to DSCP 24. So the question is why does it say 0 with the show command. I've done exactly the same on a 6509 and there I can see the counters changing.

C3560#show policy-map interface vlan 133

Vlan133

Service-policy input: test

Class-map: test (match-any)

0 packets, 0 bytes

offered rate 0 bps, drop rate 0 bps

Match: access-group name test

0 packets, 0 bytes

rate 0 bps

Class-map: class-default (match-any)

0 packets, 0 bytes

offered rate 0 bps, drop rate 0 bps

Match: any

0 packets, 0 bytes

rate 0 bps

class-map match-any test

match access-group name test

!

policy-map test

class test

set dscp 24

!

interface GigabitEthernet0/14

switchport access vlan 133

switchport mode access

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos vlan-based

spanning-tree portfast

!

interface Vlan133

no ip address

service-policy input test

!

ip access-list standard test

permit any

1 ACCEPTED SOLUTION

Accepted Solutions

Re: show policy-map interface question (QoS)

This has been discussed many times on here and is a limitation of the platform (same for almost all the fixed configuration Catalysts). The simple answer is the counters don't work and there is no tweak you can perform to make them work. The only command that shows you any half-useful statistics is 'show mls qos interface statistics'. This will show you counters for the incoming & outgoing DSCP & CoS values, plus two counters for 'Inprofile' and 'Outprofile'. These last two counters show you what traffic has adhered to its configured bandwidth within a policy and what hasn't. It doesn't show you individual counters for each class, nor does it show you whether the action was to drop or mark-down.

The older Catalyst 3550 had much better counters available with the same command, however the 'show policy-map interface' command didn't work on this platform either.

HTH

Andy

2 REPLIES
New Member

Re: show policy-map interface question (QoS)

I just found this to answer my own question above:

The show policy-map interface command is not supported on 3750 and 3560 switches, even though it is allowed to be typed in the CLI.

http://supportwiki.cisco.com/ViewWiki/index.php/Unable_to_display_QoS_information_at_the_port_level_with_the_show_policy-map_interface_command_in_Catalyst_3750_switch

Re: show policy-map interface question (QoS)

This has been discussed many times on here and is a limitation of the platform (same for almost all the fixed configuration Catalysts). The simple answer is the counters don't work and there is no tweak you can perform to make them work. The only command that shows you any half-useful statistics is 'show mls qos interface statistics'. This will show you counters for the incoming & outgoing DSCP & CoS values, plus two counters for 'Inprofile' and 'Outprofile'. These last two counters show you what traffic has adhered to its configured bandwidth within a policy and what hasn't. It doesn't show you individual counters for each class, nor does it show you whether the action was to drop or mark-down.

The older Catalyst 3550 had much better counters available with the same command, however the 'show policy-map interface' command didn't work on this platform either.

HTH

Andy

1254
Views
7
Helpful
2
Replies
CreatePlease to create content