Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

show vtp counters - No Trunk listed

I have the folllowing setup:

[ Cisco 2691 ] ------- [ Cisco 2960g ] ------- [ Cisco 3750 ]

The Cisco 3750 is the VTP server for the network.

The Cisco 2960 is the "core switch" for the network, there are multiple 2960 access switches off the 2960g.

The Cisco 2691 is the main Router for the network.

The trunk between the Cisco 2691 and the 2960g is Etherchannel with 2 links in it.

VTP is able to propagate throughout the network to all other switches, except the 2691 router.

On the 2960g switch, if I run "show vtp counters", I see all the trunks listed, including the trunk to the 2691 router. There are join transmitted across the trunk to the 2691, but no join received.

On the 2691 router, if I run "show vtp counters", I don't see any listed trunks.

The trunk between the 2691 router is operational as a trunk and is servicing all the vlan's, so I know that this trunk is working.

There are no vlan restrictions across any trunks.

So the problem is, I created a new vlan on the VTP server (3750), all the switches got the VTP update, but the Cisco 2691 did not get the update.

2960g Trunk Config:

interface Port-channel6
description EtherChannel to Cisco2691
switchport trunk native vlan 1000
switchport mode trunk
keepalive 1
!

interface GigabitEthernet0/19
description EtherChannel to Cisco2691
switchport trunk native vlan 1000
switchport mode trunk
keepalive 1
speed 100
duplex full
channel-group 6 mode on
!
interface GigabitEthernet0/20
description EtherChannel to Cisco2691
switchport trunk native vlan 1000
switchport mode trunk
keepalive 1
speed 100
duplex full
channel-group 6 mode on

Cisco 2691 Trunk Config:

interface Port-channel1
switchport trunk native vlan 1000
switchport mode trunk
keepalive 1
!
interface FastEthernet1/0
description EtherChannel to Cat2960G-0
switchport trunk native vlan 1000
switchport mode trunk
duplex full
speed 100
keepalive 1
no cdp enable
channel-group 1 mode on
!
interface FastEthernet1/1
description EtherChannel to Cat2960G-0
switchport trunk native vlan 1000
switchport mode trunk
duplex full
speed 100
keepalive 1
no cdp enable
channel-group 1 mode on
!

Any thoughts ideas would be helpful.

Thanks.

Everyone's tags (2)
4 REPLIES

Re: show vtp counters - No Trunk listed

what does the output of "show vtp status" show for the 2691 and 2960g?

do the domains match and what vtp modes are the switches in? also is pruning enabled?

hth

andy

Community Member

Re: show vtp counters - No Trunk listed

Cisco2691#show vtp status

VTP Version                     : 2

Configuration Revision          : 17

Maximum VLANs supported locally : 256

Number of existing VLANs        : 15

VTP Operating Mode              : Client

VTP Domain Name                 : vtp-domain-0

VTP Pruning Mode                : Enabled

VTP V2 Mode                     : Enabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0x50 0x0B 0x0B 0xC3 0xF8 0xC5 0xB4 0x83

Configuration last modified by 10.29.60.11 at 5-13-08 15:39:30

Cat2960G-0#show vtp status

VTP Version                     : running VTP2

Configuration Revision          : 21

Maximum VLANs supported locally : 255

Number of existing VLANs        : 16

VTP Operating Mode              : Client

VTP Domain Name                 : vtp-domain-0

VTP Pruning Mode                : Disabled

VTP V2 Mode                     : Enabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0x2A 0xC7 0xCC 0x4D 0xFC 0xF2 0x69 0xDD

Configuration last modified by 10.29.60.11 at 11-27-09 17:01:03

Cat3750G-48TS-0#show vtp status
VTP Version                     : running VTP2
Configuration Revision          : 21
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 16
VTP Operating Mode              : Server
VTP Domain Name                 : vtp-domain-0
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Enabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x2A 0xC7 0xCC 0x4D 0xFC 0xF2 0x69 0xDD
Configuration last modified by 10.29.60.11 at 11-27-09 17:01:03
Local updater ID is 10.29.60.11 on interface Vl2 (lowest numbered VLAN interface found)

VTP prunning is not enabled on any trunk or interface in the network.

Purple

Re: show vtp counters - No Trunk listed

   On the 2691 what are the ports you are using are they part of a 4 or 16 port hwic ???    Also you could try reinputting the domain name just in case someone accidently put a space at the end of the domain name . You could also try disabling vtp pruning on the 2691 to match the other switches.

Community Member

Re: show vtp counters - No Trunk listed

yah they are part of a 16 port hwic.

I had to do a workaround just now to get this working. I setup a new trunk between the 2691 router and the 2960g switch, disabled all vlans from travelling across the trunk. Brought the trunk up and VTP came across right away on the new trunk.

2241
Views
0
Helpful
4
Replies
CreatePlease to create content