Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Simple port taggin?

I'm replacing some allied telesyn switches with 3750's. I need to create a vlan (Vlan 3) and tag all my port for this vlan. We use Nortel Voip phones that belong to Vlan3 and go into the same port as our Data Vlan (Vlan 1). On the cheap Allied I just specified all the ports I wanted to be tagged. How do I do this with these 3750's CLI. Thanks.

9 REPLIES
Hall of Fame Super Bronze

Re: Simple port taggin?

If you are placing these 3750s as Layer2 devices:

1) Create the Vlan

Switch(config)#Vlan 3

Switch(config)#name Voice

2) assign membership on port

Switch(config-if)#switchport voice vlan 3

Switch(config-if)#spanning-tree portfast

You will need to create trunks on inter-switch links to carry both Vlan1 and Vlan3.

Vlan1 comes with the switch by default, thus no need for configuration.

New Member

Re: Simple port taggin?

Now, by assigning the port to vlan3, does that not take it out of vlan1? I might be missing something...

New Member

Re: Simple port taggin?

Not that way.If you connect a PC also to that port its data will be considered as coming from vlan1.vlan 3 here is only for the voice traffic.

Adding to Edison's point,

As soon as you add voice vlan port fast is enabled automatically.More details at,

http://www.cisco.com/en/US/docs/switches/lan/catalyst3550/software/release/12.1_12c_ea1/configuration/guide/swvoip.html#wp1030825

Hope this helps.

New Member

Re: Simple port taggin?

I got a reply from our Cisco rep at the phone company (our Voip shoots over to the phone company). This is the example he gave me.

interface FastEthernet0/2

description Trunk to phone-pc data vlan 10 voice vlan 20

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport trunk allowed vlan 10,20

switchport mode trunk

srr-queue bandwidth share 10 20 40 30

srr-queue bandwidth shape 10 0 0 0

priority-queue out

mls qos trust dscp

spanning-tree portfast trunk

My only question is the:

srr-queue bandwidth share 10 20 40 30

srr-queue bandwidth shape 10 0 0 0

The 10 20 40 30 are those percentage of the port bandwidth available to each queue? As far as the shape 10 0 0 0 I do need some clarification on this as well. I apologize for the dumb questions but I'm not used to using switches with functionality lol.

Silver

Re: Simple port taggin?

As far as the shape 10 0 0 0 I do need some clarification on this as well. I apologize for the dumb questions but I'm not used to using switches with functionality lol.

[salman]

that is to shape queue # 1 which is a priority queue. So your queue #1 will get 10% of the bandwidth and nothing more. Once you configure shpaing , you cannot use sharing on the same quueue. The idea of shaping is to restrict the bandwidth to a certain value. Sharing means the queues will atleast get whatever is configured , but can also expand beyond ( i.e share ) whatever is configured for these queues. Since Priority queues have the possibility of starving other regular queues , sharing is recommended for priority queues.

thanks

Salman.

New Member

Re: Simple port taggin?

so.. Sharing is the prefered configuration? Will that not pull bandwidth away from the other queues? Like you said starve them?

Silver

Re: Simple port taggin?

thats why we restrict it to 10% . restricting it to 10% is better then letting it have at entire bandwidth :).

Sharing on Priority queue could cause starvation for other queues .

thanks

Salman.

New Member

Re: Simple port taggin?

so I cannot have both shape and shared. correct? can I set those settings globally or is strictly per port?

Silver

Re: Simple port taggin?

No. Once you configure shaping and sharing both for a specific queue , shaping takes precedence. Sharing configured on that queue will have no effect.

thanks

Salman.

135
Views
0
Helpful
9
Replies