Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Simple Routing problem

Hello, i have RAS5300 connected to a 3845 router.

RAS5300 faste0 ip 10.10.10.2

3845 gigabite0 ip 10.10.10.1

when i am on console of the RAS5300, i can ping 10.10.10.1, but when i dialin to the RAS, i get ip address from the pool RAS, say 10.10.12.10, i try from CMD to ping 10.10.10.1, but i fail, i can ping 10.10.10.2 no problem.

thanks for any help:

Current configuration : 2383 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname MANS-RAS5300

!

boot-start-marker

boot-end-marker

!

enable secret xxx

!

spe 1/0 2/9

firmware location system:/ucode/mica_port_firmware

!

!

resource-pool disable

!

no aaa new-model

ip subnet-zero

ip name-server 212.xx.xxx.2

ip name-server 212.xx.xxx.3

!

!

isdn switch-type primary-net5

!

!

!

!

!

!

!

!

!

!

username mans password 0 xxxxxx

!

!

controller E1 0

clock source line primary

pri-group timeslots 1-31

!

interface Ethernet0

no ip address

shutdown

!

interface Serial0:15

description E1-0

ip unnumbered FastEthernet0

encapsulation ppp

dialer pool-member 1

isdn switch-type primary-net5

isdn incoming-voice modem

peer default ip address pool RAS

ppp authentication chap

!

interface FastEthernet0

ip address 10.10.10.2 255.255.255.0

duplex auto

speed auto

!

interface Group-Async1

ip unnumbered FastEthernet0

ip nat inside

encapsulation ppp

async mode interactive

peer default ip address pool RAS

ppp authentication chap DIAL-UP

group-range 1 240

!

interface Dialer1

description S0

bandwidth 64

ip address 10.10.11.1 255.255.255.0

encapsulation ppp

dialer pool 1

dialer-group 1

autodetect encapsulation ppp

ppp authentication chap callin

!

ip local pool RAS 10.10.12.10 10.10.12.250

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.10.1

no ip http server

!

!

!

!

!

!

!

!

line con 0

line 1 30

modem InOut

transport input all

autoselect ppp

line 31 240

line aux 0

line vty 0 4

login local

!

end

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Simple Routing problem

Baha

To advertise 10.10.12.0 to the 3845 you would need to have a route to advertise and you would need to configure a dynamic routing protocol. The details of how to do that would vary somewhat depending on which routing protocol you use. I will illustrate with EIGRP.

First you would need to have a route to advertise. You can do this by putting the subnet on an interface and including that interface into the routing protocol or you could configure a static route and redistribute the static route into the routing protocol. I will illustrate putting the subnet on an interface.

interface loopback 0

ip address 10.10.12.1 2555.255.255.0

Then you need to configure the routing protocol and include the interfaces (the interface to establish the neighbor relationship and the interface to advertise the address range).

router eigrp 100

network 10.10.10.0 0.0.0.255

network 10.10.12.0 0.0.0.255

Since the ppp negotiation will create individual /32 host routes I would also suggest that you configure a summary address on the LAN interface.

interface fastethernet 0

ip summary-address eigrp 100 10.10.12.0 255.255.255.0

You would also need to configure EIGRP routing on the 3845 and include the 10.10.10.1 interface into EIGRP. And if you do that it is liekly that the 3845 will advertise routes to you so that you do not need the static default route configured.

HTH

Rick

6 REPLIES
Silver

Re: Simple Routing problem

Hi ,

change ip route 0.0.0.0 0.0.0.0 10.10.10.1

to ip route 0.0.0.0 0.0.0.0 dia 1.

What is the purpose on nat which is applied on Group-Async1 ? Have you defined nat pool for that one..

Thanks,

satish

New Member

Re: Simple Routing problem

Hello & thanks for your quick response.

actually i will take the nat from group-async1 because no purpose.

but i would like to ask why woudnt the route to 10.10.10.1 work?

and what will the route to dia 1 would do?

thank you.

Silver

Re: Simple Routing problem

Hi ,

I think fastethernet of RAS is conected to gig interface of router.

If you traceroute to 10.10.10.1 is it dropping at 10.10.10.2 ..

add dialer-list 1 protocol ip permit command in global config for interesting traffic.

Thanks,

satish

Hall of Fame Super Silver

Re: Simple Routing problem

Baha

While satish second suggestion is much better than his first (sending the default route out the dialer rather than out the FastEthernet is almost certainly not what your environment needs) and without a dialer list the dialer will not work. I am confident that the problem is not on your 5300. If you check I believe that you will find that the 3845 does not have a route to 10.10.12.0. You can fix the problem by having the 5300 advertise the 10.10.12.0 network to the 3845 or you can fix the problem by configuring a static route on the 3845 for 10.10.12.0 pointing to the 5300.

As a separate item I am puzzled by this line on your group async:

ppp authentication chap DIAL-UP

This names an authentication method called DIAL-UP which would make sense if you were using aaa authentication for dial in users. But the 5300 is configured with no aaa new-model. Can you clarify what is happening here?

HTH

Rick

New Member

Re: Simple Routing problem

Baha

While satish second suggestion is much better than his first (sending the default route out the dialer rather than out the FastEthernet is almost certainly not what your environment needs) and without a dialer list the dialer will not work. I am confident that the problem is not on your 5300. If you check I believe that you will find that the 3845 does not have a route to 10.10.12.0. You can fix the problem by having the 5300 advertise the 10.10.12.0 network to the 3845 or you can fix the pr oblem by configuring a static route on the 3845 for 10.10.12.0 pointing to the 5300.

hello,

thanks for your ideas.

id rather advertise the 10.10.12.0 network to the 3845. can you help me with command for advertising a network to next hob?

the DIAL-UP i had it there because i am not yet finished with the setup of radius, so i will be using it later on, no puzzle :)

Hall of Fame Super Silver

Re: Simple Routing problem

Baha

To advertise 10.10.12.0 to the 3845 you would need to have a route to advertise and you would need to configure a dynamic routing protocol. The details of how to do that would vary somewhat depending on which routing protocol you use. I will illustrate with EIGRP.

First you would need to have a route to advertise. You can do this by putting the subnet on an interface and including that interface into the routing protocol or you could configure a static route and redistribute the static route into the routing protocol. I will illustrate putting the subnet on an interface.

interface loopback 0

ip address 10.10.12.1 2555.255.255.0

Then you need to configure the routing protocol and include the interfaces (the interface to establish the neighbor relationship and the interface to advertise the address range).

router eigrp 100

network 10.10.10.0 0.0.0.255

network 10.10.12.0 0.0.0.255

Since the ppp negotiation will create individual /32 host routes I would also suggest that you configure a summary address on the LAN interface.

interface fastethernet 0

ip summary-address eigrp 100 10.10.12.0 255.255.255.0

You would also need to configure EIGRP routing on the 3845 and include the 10.10.10.1 interface into EIGRP. And if you do that it is liekly that the 3845 will advertise routes to you so that you do not need the static default route configured.

HTH

Rick

158
Views
5
Helpful
6
Replies