Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

single svi on multiple switches

Hi All

I have attached a simplified network diagram of a network that needs to be implemented.

I have a wireless network that needs to be on the same L2 network, even across multiple L3 switches. The mobile wireless devices are configured with static IP and gateway. The objective is that the mobile devices are able to talk to any other devices on the same or different vlan.

As seen on the diagram, I have configured a single vlan (Vlan 10) spanning multiple Layer 3 switches (prelim selection would be cisco 3560 switches). I know this can be done. My question is, can this vlan have the same SVI (i.e. identical IP address) across all the switches? Or will this result in routing errors? In this example, the mobile devices need to communicate with both the primary and secondary servers. Routing is achieved via Single Area OSPF. The communication should be resilient against switch failure, so in this example, if SW3 fails, mobile devices should still be able to communicate with the primary server via AP on SW1 or SW2.

Your feedback would be greatly appreciated. thanks.

 

SVI, vlans,  

 

Everyone's tags (1)
5 REPLIES

Hi,Unfortunately you won't be

Hi,

Unfortunately you won't be able to span same IP address on multiple  L3 switches with same area/network.

What you can do is create the SVI on switch 1. This will be your main L3 device on the network unless you want to achieve some kind of redundancy. And then you can create access ports for the individual AP.

example:

SW1-SW3

interface GI1/0/2 = connected to AP

int gi1/0/2

switchport access vlan 10

switchport mode access

 

HTH,

Terence

New Member

Hello TerenceThanks for the

Hello Terence

Thanks for the reply. 

Just so I understand correctly, your approach is to create Vlan 10 on all switches, but to assign it an IP address only in SW1.

In this case, if SW1 fails, the mobile devices will only be able to communicate with devices within Vlan 10, not with any other vlans. This is not desirable, as i need to provide redundancy in the case where if any one geographical location is not available, the mobile devices are still able to reach all available Vlans within the network. E.g. if SW1 is not available, the mobile devices should still be able to reach vlan 200 on SW3, either through AP on SW2 or SW3.

Are there any alternative strategies that can be implemented to achieve this?

Thanks

Mufaddal

 

Hi Mufaddal,You will need to

Hi Mufaddal,

You will need to configure redundancy between your core switches.

You can either go with VRRP,GLBP or HSRP (recommended).

You can configure as per below:

Note that am using HSRP as an example:

SW1:

int vlan 10

ip address 192.168.10.2 255.255.255.0

standby ip 192.168.10.1

standby 1 preempt

standby 1 priority 120

standby 1 track 'interface or you can even create an ip sla and map to it'

 

SW2:

int vlan 10

ip address 192.168.10.3 255.255.255.0

standby ip 192.168.10.1

standby 1 preempt

standby 1 priority 110

standby 1 track 'interface or you can even create an ip sla and map to it'

 

SW3:

 

int vlan 10

ip address 192.168.10.4 255.255.255.0

standby ip 192.168.10.1

standby 1 preempt

standby 1 priority 100

standby 1 track 'interface or you can even create an ip sla and map to it'

 

HTH.

Terence

New Member

Hello TerenceThanks for the

Hello Terence

Thanks for the recommended solution above. I will be trying this out in my test setup soon.

I do have a few more queries though :

1) In the above config, if SW1 is available, all traffic from mobile devices will be routed through SW1, regardless of which AP the mobile device is connected to. Is my understanding correct?

2) Should I be enabling ospf on vlan10 of each switch?

3) How would this scale to a bigger installation, example more AP's per switch or more switches being added in the future

4) for the dot1q trunk links, i will only need to allow vlan10, the rest of the vlans can be removed. Is this ok?

Thanks again

Mufaddal

Hello Mufaddal, Glad to help.

Hello Mufaddal,

 

Glad to help.

 

1) Yes, from the above config SW1 will be the default GW for vlan 10 unless there's an issue with SW1 in which SW2 will take ownership of GW and so on.

 

2)Yes, you will need to enable OSPF on all switches.

 

3)There will be no impact, as you will be adding the additional AP as access port on the switch unless you are using multiple SSID/vlan on the AP itself in which you will need to configure same HSRP config for all additional vlan's.

 

4) Well it depends on your setup. If you have multiple vlans spanning across all 3 switches, you will need to allow those vlan's as well. 

 

HTH.

Please rate helpful post.

Regards,

Terence

575
Views
10
Helpful
5
Replies
CreatePlease to create content