Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Sip passing through nat but rtp is not - no audio

Sip passing through nat but rtp is not

I'm looking at traffic leaving my router with a sniffer. I see SIP traffic but I do not see RTP traffic.  The phones ring on both sides but I do not get any audio.

interface f0/0.100

ip address 192.168.10.1 255.255.255.0

ip nat outside

ip nat pool VoIP 192.168.10.1  192.168.10.1 prefix-length 24

ip nat inside source route-map VoIP pool VoIP overload
ip nat inside source static tcp 10.1.1.2 49201 192.168.10.54 49201 extendable

access-list 1 permit ip host 10.1.1.2 any


!
route-map VoIP permit 10
match ip address 1
match interface  f0/0.100
set interface  f0/0.100

6 REPLIES
Cisco Employee

Re: Sip passing through nat but rtp is not - no audio

Hello,

I guess you need to configure additional port maps for VoIP. Please check out this document:

http://www.cisco.com/en/US/docs/ios/ipaddr/configuration/guide/iad_pat_pt_rng.html

Hope this helps.

Regards,

NT

New Member

Re: Sip passing through nat but rtp is not - no audio

Do I need to enable anything voip related for this to work?

Like voice service voip ?

Cisco Employee

Re: Sip passing through nat but rtp is not - no audio

Hello,

You can enable "ip nat service sip" or "ip nat service h323" and "ip nat

service h225" commands. As per the documentation, they are enabled by

default. In the latest IOS there is a new feature added to Cisco IOS that

ensures that even RTP packets get translated to one of the allowed ports as

specified by the RFC. The command to enable the feature is "ip nat service

allow-sip-even-rtp-ports"

http://www.cisco.com/en/US/prod/collateral/iosswrel/ps6537/ps6586/ps6640/pro

d_white_paper0900aecd80597bc7.html

Hope this helps.

Regards,

NT

New Member

Re: Sip passing through nat but rtp is not - no audio

My IOS does not support the portmap command.

New Member

Re: Sip passing through nat but rtp is not - no audio

Ok I configured the portmap command and I still do not get any audio.

This works with a linksys router but not with a cisco 2600 router

Bronze

Thanks Nagaraja Thanthry,

Thanks Nagaraja Thanthry, that correct, I had the same issue and solved by using the instructions above ( ip nat service allow-sip-even-rtp-ports).

 

Regards

5161
Views
5
Helpful
6
Replies