Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Slow first ping packet

I have a client pc that get a slow first ping response each time they ping a server (even if there is no delay between runs) there are other users on the same switch that do not see this delay *example below. The clients are 4 to 6 hops away from the target servers and hop 3/4 are on ether end of a 100mb metro Ethernet connection (office are about 1 mile apart but who knows how much cable that is). I know there is some latency that comes in from time to time due to the metro but I don't understand what could cause some users to see this first packet delay. Any thoughts?

Thanks

Reply from 10.4.10.1: bytes=32 time=31ms TTL=124 Reply from 10.4.10.1: bytes=32 time=1ms TTL=124 Reply from 10.4.10.1: bytes=32 time<1ms TTL=124 Reply from 10.4.10.1: bytes=32 time<1ms TTL=124

5 REPLIES
New Member

Re: Slow first ping packet

Hi Timpoth, are you using DNS in the ping command? If so, it's possible the DNS lookup is causing the first delay. Also, if you try it immediately after the first run of answers, do they all go fast? If you wait until it gets flushed from cache (PC's), it will have to ARP for it again. This also may be your first delay. You can experiment with that by finding the MAC address of the server and statically cache it. Frank

New Member

Re: Slow first ping packet

Thanks for the reply, the pings were done via IP and there was no delay between runs yet the first ping response was consistently slow. In looking at a wireshark capture when the first packet goes out there is nothing else going on, it just takes a while for the reply to come back.

Thanks

New Member

Re: Slow first ping packet

I think it has to do with TCP slow start and it is by design.

Re: Slow first ping packet

It's normal. The first package has to find the entry in the ARP table.

New Member

Re: Slow first ping packet

Yep, most likely just ARP lookup.

You can try pinging from the switch that the host is connected to which should give you an idea if there is an issue there.

3562
Views
0
Helpful
5
Replies