Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Slow Internet 1841 - Please check config

Hi All,

Hoping you can help. I have recently replaced a terrible ISP router with a Cisco 1841 router which seems configured correctly however ever since connecting this up I am having very weird internet issues.. 

 

For example when trying to browse a webpage it will give me "page cannot be displayed" however if I try a few times it loads but not correctly - However if i get the website to load correctly after a good few times it then seems to load OK (As if it is cached) but as soon as I go on a webpage I have not used it either slow or "page cannot be displayed"

 

I tried plugging my technicolour router back in and I get normal internet again. Please see below the config and advise me if anything is incorrect. The internet is that intermittent I have had to plug the Technicolour back in until I get a resolve.

 

I have DNS / DHCP running on a Domain controller - The router is simply the default gateway & the device my ADSL plugs into.

 

CCAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!

User Access Verification

Username: username
Password: 

talktalk.router#sh run
Building configuration...

Current configuration : 3279 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname talktalk.router
!
boot-start-marker
boot-end-marker
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local 
aaa session-id common
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
ip ips po max-events 100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username username
!

no crypto isakmp ccm
!
!
!
!
interface FastEthernet0/0
 description (Inbound Connection to Fortinet Firewall))
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description ((Connection to Playstation 4))
 no ip address
 duplex auto
 speed auto
!
interface ATM0/0/0
 description Connected to ADSL Line
 no ip address
 load-interval 60
 no atm ilmi-keepalive
 dsl operating-mode auto 
 hold-queue 224 in
 pvc 0/38 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface Dialer0
 description Bound to ATM0
 ip address negotiated
 ip mtu 1458
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 load-interval 30
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 no snmp ifindex persist
 ppp authentication chap callin
 ppp chap hostname 
 ppp chap password 
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
!
!
!
control-plane
!
!
!
!

!
!
banner login ^CCCAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
banner motd ^CCC

***********************************************************************
***********************************************************************
** 
***********************************************************************

^C
!
line con 0
line aux 0
line vty 0 4
 transport input all
!
end

talktalk.router#  exit

8 REPLIES
New Member

I have also tried plugging

I have also tried plugging direct into fa0/0 (Which is where the Fortinet device sits) and giving myself a static IP and I still get a kind of intermittent Internet connection, which is cleared up if I plug in the router provided by talk talk.

 

I suspect I have a config error somewhere however the router is not providing any feedback so your feedback would be great.

 

thanks

New Member

Hi, Please try by removing

Hi,

 

Please try by removing this line

ip ips po max-events 100

 

Regards,

Naisam

New Member

Thank you for the reply. I

Thank you for the reply.

 

I will try this and write back with results. 

 

 

New Member

Hi. Thanks for the reply. I

Hi.

 

Thanks for the reply. I tried by removing the line and didnt get any success. I decided to give myself a static DNS server and now it is fixed so it were an issue with DNS. I have now changed the way DNS is distributed.

I do have another issue which is the internet speed, If I browse the internet I do not really notice any difference but If I run a speedtest I am only getting 7mb! which if I plug in my ISP provided router I am getting 17mbps.

 

I am going to copy the lastest config - Which has changed quite a bit as my speedtests were originally showing 2mbps but after I have added lines I have managed to get it to 7mb.

 

Does anyone have any idea what I can try change to improve the speed?

 


talktalk.router#sh run
Building configuration...

Current configuration : 4018 bytes
!
! Last configuration change at 20:51:31 UTC Sun Apr 20 2014 by 
version 15.1
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname talktalk.router
!
boot-start-marker
boot-end-marker
!
!
no logging buffered
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local 
!
!
!
!
!
aaa session-id common
no ip source-route
!
!
!
!
!
ip cef
no ip domain lookup
multilink bundle-name authenticated
!
!
license udi pid CISCO1841 sn FCZ094921PK
username  privilege 15 secret 
!
!
ip tcp synwait-time 10

!
!
!
interface Null0
 no ip unreachables
!
interface FastEthernet0/0
 description (Inbound Connection to Fortinet Firewall))
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description ((Connection to
 no ip address
 duplex auto
 speed auto
!
interface ATM0/0/0
 description Connected to ADSL Line
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 load-interval 30
 atm ilmi-keepalive
 dsl lom 250
 hold-queue 224 in
 pvc 0/38 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface Dialer0
 description Bound to ATM0
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly in max-reassemblies 1024
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 ppp authentication chap pap callin
 ppp chap hostname talktalkbusiness.net
 ppp chap password
 ppp ipcp predictive
 no cdp enable
!
interface Dialer1
 no ip address
 shutdown
!
ip forward-protocol nd
!
!
no ip http server
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 192.168.0.62 80 interface Dialer0 80
ip nat inside source static tcp 192.168.0.62 25 interface Dialer0 25
ip nat inside source static tcp 192.168.0.62 443 interface Dialer0 443
ip nat inside source static tcp 192.168.0.62 3389 interface Dialer0 3389
ip route 0.0.0.0 0.0.0.0 Dialer0

access-list 1 permit 192.168.0.0
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 101 permit ip 192.168.0.0 0.0.0.255 any log
access-list 101 deny   ip any any log
!
!
!
control-plane
!
!
banner login ^CCCAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
banner motd ^CCC

^C
!
line con 0
line aux 0
line vty 0 4
 access-class 101 in
 transport input all
!
scheduler allocate 20000 1000
end

hi,could you add these lines

hi,

could you add these lines and test again?

int d0

ip mtu 1492

 

int f0/0

ip tcp adjust-mss 1452

 

New Member

Hi. Thank you for taking the

Hi.

 

Thank you for taking the time to look at my problem, I have added these lines and just run a speedtest and unfortunately it is still at 6 - 7mb. 

 

I have also tried adding the same MTU value for both interfaces still with no luck... 

 

Anyone else have any suggestions? 

New Member

Not sure if this will help

Not sure if this will help anyone

 

talktalk.router#show dsl interface atm0/0/0
ATM0/0/0
Alcatel 20150 chipset information
                ATU-R (DS)                      ATU-C (US)
Modem Status:    Showtime (DMTDSL_SHOWTIME)
DSL Mode:        ITU G.992.1 (G.DMT) Annex A
ITU STD NUM:     0x01                            0x1
Vendor ID:       '    '                          'IFTN'
Vendor Specific: 0xDBB0                          0x71C8
Vendor Country:  0x04                            0xB5
Capacity Used:   92%                             95%
Noise Margin:     9.0 dB                          9.0 dB
Output Power:    20.0 dBm                        10.0 dBm
Attenuation:     17.5 dB                         10.0 dB
FEC ES Errors:    0                               0
ES Errors:        0                               0
SES Errors:       0                               0
LOSES Errors:     0                               0
UES Errors:       0                               0
Defect Status:   None                            None
Last Fail Code:  None
Watchdog Counter: 0xA2
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction:     0x15
Interrupts:      3983 (0 spurious)
PHY Access Err:  0
Activations:     3
LED Status:      ON
LED On Time:     100
LED Off Time:    100
Init FW:         ASW_init_3_8_131.bin
Operation FW:    ASW_R3_8_131.bin
FW Source:       embedded
FW Version:      3.8.131

                 Interleave             Fast    Interleave              Fast
Speed (kbps):          8128                0           896                 0
DS User cells:       559313                0
US User & Idle cells:                               1390784                0
Reed-Solomon EC:          0                0             0                 0
CRC Errors:               0                0             0                 0
Header Errors:            0                0             0                 0
Bit Errors:               0                0
BER Valid sec:            0                0
BER Invalid sec:          0                0

LOM Monitoring : Enabled
LOM watch configured for 250 times
LOM appeared continuously for 0 times


DMT Bits Per Bin
000: 0 0 0 0 0 0 0 5 8 9 A C C C C D
010: D C C C D D D C C B B A A 9 0 0
020: 0 0 0 0 0 0 8 9 9 A B B B C C C
030: C D D D D D D D D D D D D D D D
040: D D D C D D D D D D D D D D D D
050: C D D C C D C C C C C C C C 2 C
060: C C C C C C C C C C C C C C C C
070: C C C C C C B B B B B B B B B B
080: B B B B B 0 B B B B B B B B B B
090: B B B 0 B B B B 0 B B B B B B B
0A0: B B B B B B B B B B B B B B B A
0B0: A A A A A A A A A A A A A A A 9
0C0: 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9
0D0: 9 8 7 4 7 9 9 9 9 9 9 9 9 9 9 9
0E0: 9 9 9 9 9 9 9 9 9 9 8 8 8 8 7 6
0F0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

DSL: Training log buffer capability is not enabled
talktalk.router#

New Member

I think I have found the

I think I have found the issue.. I suspect my ADSL HWIC card does not allow ADSL2+

 

1117
Views
0
Helpful
8
Replies
CreatePlease to create content