Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Slow InterVlan Routing Cisco 3560x

Hi Everyone,

I have been learning a lot about Cisco switches and I had one setup with a few vlans (10,20,70). Recently I enabled inter-vlan routing on the switch and everything seemed to be going ok, and then suddenly file transfer rates between computers on one vlan to another became less than 3MB/s. However file transfers between any computer on the same vlan were around 100-120MB/s. I do have STP running on this switch and two other SG-300-28P switches, but I don't think that is the problem but I may be wrong. The Cisco 3560x is configured as the root bridges and it is running in r-pvst, and the other two SG-300-28P are running in rstp.

Some configuration snippets:

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname GBe1

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

system mtu routing 9000

authentication mac-move permit

ip routing

spanning-tree mode rapid-pvst

spanning-tree loopguard default

spanning-tree extend system-id

spanning-tree vlan 1,10,20,70 priority 24576

spanning-tree vlan 1,10,20,70 forward-time 12

spanning-tree vlan 1,10,20,70 max-age 16

!

!

!

!

vlan internal allocation policy ascending

!

!

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,10,20,70

switchport mode trunk

switchport nonegotiate

!

interface Port-channel2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,10,20,70

switchport mode trunk

switchport nonegotiate

!

interface GigabitEthernet0/1

switchport access vlan 10

switchport mode access

switchport nonegotiate

!

interface GigabitEthernet0/11

switchport access vlan 20

switchport mode access

switchport nonegotiate

!

interface GigabitEthernet0/14

switchport access vlan 70

switchport mode access

switchport nonegotiate

!

interface GigabitEthernet0/39

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,10,20,70

switchport mode trunk

switchport nonegotiate

channel-protocol lacp

channel-group 1 mode active

!

interface GigabitEthernet0/40

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,10,20,70

switchport mode trunk

switchport nonegotiate

channel-protocol lacp

channel-group 1 mode active

!

interface GigabitEthernet0/41

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,10,20,70

switchport mode trunk

switchport nonegotiate

channel-protocol lacp

channel-group 1 mode active

!

interface GigabitEthernet0/42

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,10,20,70

switchport mode trunk

switchport nonegotiate

channel-protocol lacp

channel-group 1 mode active

!

interface GigabitEthernet0/43

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,10,20,70

switchport mode trunk

switchport nonegotiate

channel-protocol lacp

channel-group 2 mode active

!

interface GigabitEthernet0/44

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,10,20,70

switchport mode trunk

switchport nonegotiate

channel-protocol lacp

channel-group 2 mode active

!

interface GigabitEthernet0/45

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,10,20,70

switchport mode trunk

switchport nonegotiate

channel-protocol lacp

channel-group 2 mode active

!

interface GigabitEthernet0/46

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,10,20,70

switchport mode trunk

switchport nonegotiate

channel-protocol lacp

channel-group 2 mode active

!

interface Vlan1

no ip address

spanning-tree link-type point-to-point

!

interface Vlan20

ip address 10.7.7.2 255.255.255.0

spanning-tree link-type point-to-point

!

interface Vlan70

ip address 10.7.12.2 255.255.255.0

spanning-tree link-type point-to-point

!

interface Vlan10

ip address 10.7.5.2 255.255.255.0

spanning-tree link-type point-to-point

!

ip http server

ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 10.7.7.70

!

ip sla enable reaction-alerts

logging esm config

Thank you for your help in advance.

Thanks!

Jarrett http://www.jarrettcadiz.com http://www.cloudchase.net/company/jarrettcadiz
2 ACCEPTED SOLUTIONS

Accepted Solutions

Slow InterVlan Routing Cisco 3560x

Hi ,

I would try:

system mtu routing 1504

Dan

Purple

Slow InterVlan Routing Cisco 3560x

I agree I would   try changing themtu back to 1500 .  If a device is using 9000 byte packets and you are transfering between vlans everything gets fragmented because  these models cannot  route jumbo frames .  This is a platform restriction.

3 REPLIES

Slow InterVlan Routing Cisco 3560x

Hi ,

I would try:

system mtu routing 1504

Dan

Purple

Slow InterVlan Routing Cisco 3560x

I agree I would   try changing themtu back to 1500 .  If a device is using 9000 byte packets and you are transfering between vlans everything gets fragmented because  these models cannot  route jumbo frames .  This is a platform restriction.

New Member

Slow InterVlan Routing Cisco 3560x

Hi Dan and Glen,

Thank you so much for replying to me. I did change the routing mtu back to default, however with it only switching I still found it going much slower than wire speed.

It later was discovered that a downstream switch (esw-540-24p) does not support Jumbo or hasn't been enabled and that was causing hiccups. With the esw-540-24p removed and routing mtu back to default, performance is now amazing on the switch once again.

Thanks you so much for your help!

Jarrett http://www.jarrettcadiz.com http://www.cloudchase.net/company/jarrettcadiz
2783
Views
0
Helpful
3
Replies
CreatePlease login to create content