Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

Slow network after creating loop, STP not working?

I have a problem with a customer network. The solution is probably really simple, but I can't see it!

The network is made out of a 3750 (Coreswitch) and multiple pairs of 2950's (Access-switches). Each 2950 has a Fiber-uplink to the Coreswitch and a Fiber-link between the two switches in the pair. All of this works fine, except for one pair of switches! When we plug in the cable between the two switches, the whole network slows down and becomes useless.

I have gathered some information from the network:

Here is a drawing of the part of the network that is giving problems, the dotted orange line between switch SW3A and SW3B is the cable that gives problems after plugging in. The network is fine after we remove the cable.

http://people.zeelandnet.nl/mikeysuus/netpro/network.jpg

Here are the configurations:

http://people.zeelandnet.nl/mikeysuus/netpro/Coreswitch-config.txt

http://people.zeelandnet.nl/mikeysuus/netpro/SW3A-config.txt

http://people.zeelandnet.nl/mikeysuus/netpro/SW3B-config.txt

I hope that someone can help me out! If you have more detailed questions about the network: just ask them and I will try to answer them.

Regards,

Michael

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: Slow network after creating loop, STP not working?

Hi Michael,

I can't tell from the configuration why the network slows down when switch A and B are directly connected.

What I do noted is that the core switch is the root switch of vlan1, hence the spanning-t priority command. In case the bridge-id of one of the access switches is lower that switch will become the root of the spanning tree for other VLANs i.e. VLAN 10.

Find out what switch is currently the root of the spanning tree per VLAN by issuing the show spanning-tree vlan x command. Where x is the VLAN number.

Make the core switch the root of the spanning tree by isuing the spanning-tree vlan 1,100,x,y,z root primary command.

In case you experience network degradation, likely caused by a loop, issue the command show spanning-tree vlan x detail to see the source of TCN BPDUs.

HTH

--Leon

* Please rate ALL posts.

8 REPLIES
Silver

Re: Slow network after creating loop, STP not working?

Hi Michael,

I can't tell from the configuration why the network slows down when switch A and B are directly connected.

What I do noted is that the core switch is the root switch of vlan1, hence the spanning-t priority command. In case the bridge-id of one of the access switches is lower that switch will become the root of the spanning tree for other VLANs i.e. VLAN 10.

Find out what switch is currently the root of the spanning tree per VLAN by issuing the show spanning-tree vlan x command. Where x is the VLAN number.

Make the core switch the root of the spanning tree by isuing the spanning-tree vlan 1,100,x,y,z root primary command.

In case you experience network degradation, likely caused by a loop, issue the command show spanning-tree vlan x detail to see the source of TCN BPDUs.

HTH

--Leon

* Please rate ALL posts.

Bronze

Re: Slow network after creating loop, STP not working?

That could be the solution, why didn't I think of that?

I made the Coreswitch the primary root with the command you provided, I'll ask the customer today if he wants to plug in the cable again.

I'll keep you updated!

Purple

Re: Slow network after creating loop, STP not working?

It'a also good practice to prune everything but the needed vlans on your trunk links on both sides . If you are not using vlan 1 for data traffic that can also be pruned off .

New Member

Re: Slow network after creating loop, STP not working?

after looking into the configuration your truck port is configured as portfast. Instead of that you must configured to uplinkfast.

New Member

Re: Slow network after creating loop, STP not working?

In the Distribution Switches:

spanning-tree mode pvst

spanning-tree portfast bpduguard default

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree vlan 1,9-10,20,99-100,180,200 priority 24576

spanning-tree vlan 660,680 priority 24576

!TRUNK CONFIGURATION

!

interface GigabitEthernet

description

switchport trunk encapsulation dot1q

In the Access Switches:

spanning-tree mode pvst

spanning-tree portfast bpduguard default

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree uplinkfast

!ACCESS PORTS

interface FastEthernet0/1

switchport access vlan 200

spanning-tree portfast --> This command is used in Access Ports and is right in your configuration

interface GigabitEthernet0/1

switchport mode trunk

spanning-tree cost 2 - In case Dual Attachement is there and need to select Primary and Seconadary path.

!

interface GigabitEthernet0/2

switchport mode trunk

Switches configurations are OK except the STP Priority Settings. As above mentioned, its best to keep the Manual Priority configuration in the Distribution Switch to avoid Malfunctioning during any Changes in the network.

Re: Slow network after creating loop, STP not working?

Assuming that your core is now configured to be the root for all the vlans, if you have a bridging loop when connecting the two access switches together, it can only be because this link is becoming forwarding on both sides, while at least one port should be alternate, the other one should be designated.

What you can ask your customer to do is do:

-1- On one of the access switch, remove all the vlans from the trunk linking it to the other access switch.

-2- connect the cable

-3- put back a single vlan on the trunk.

-4- Wait until the state of the STP has converged on both side of the link. If there is a loop, you should be able to see the wrong role and state for those ports. That could be caused by a unidirectional link failure.

-5- if everything is fine, add back the vlans one by one, or at least by groups.

It seems you have portfast configured on the core on ports going to access switches. Remove it. It's not going to cause any trouble because it has no effect on trunk ports, but it's not appropriate and could be an issue if you changed the config. The root bridge should indeed be located on the core rather than the access, but considering the depth of your network, it would not have caused the problem you are experiencing, even if incorrectly configured.

Regards,

Francois

Bronze

Re: Slow network after creating loop, STP not working?

Thank you for all your replies, I will try to test some of the things this week.

I'll keep you guys up-to-date!

Bronze

Re: Slow network after creating loop, STP not working?

Thanks everybody, the problem is solved!

The problem was that the Coreswitch wasn't the root of the STP for all VLANS's!

522
Views
12
Helpful
8
Replies
CreatePlease login to create content