Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Slow network performance across Etherchannel

Hello,

Any help or advise with this one would be appreciated!

Topology Summary:

I have a network across two floors (11th and 12th).

The 11th floor is the core network with 2 x 3750G switches with enhanced IOS. These switches have 3 vlans, WAN (vlan 100), Voice (vlan 10) and Data (vlan 20). I also have a 3560 switch connected to the core with a dot1q trunk (native vlan 1)

The 12th floor consists of 3 x 3560-48 10/100 switches and connect to the 11th floor via 2 x 2gb etherchannels configured to carry all vlans across a dot1q trunk (native vlan 1) One channel to each of the 3750's.

Problem: When people work on the 12th floor they complain of a slow network, however voice call quality is good, so this only effects the data vlan. When these people move to the 11th floor everything is fine.

My server team has ruled out any issues with AD/ Domain controllers so this has landed with me and unfortunately I can see no configuration issues or problems. Can anyone suggest what to look for?

Verified so far:

STP is as expected, blocking in the correct place. CDP topology is as I would expect and the etherchannels are using native vlan 1. The port channels are seeing no errors/dropped packets etc.

If any more info is required please ask.

Many thanks

Richard

8 REPLIES
New Member

Re: Slow network performance across Etherchannel

Hi - Are the 3750's on the 11th floor stacked with stackwise cables?? You shouldn't ahve anything in STP blcoking mode if you have an etherchannel between the floors??

New Member

Re: Slow network performance across Etherchannel

Hello - I have just added the topology. The STP is blocking at 10.80.5.103 Gi0/1 on the 12th floor.

I have read another post which may be related to the 3560's that mentions performance issues when using the SFP ports and having mls qos enabled.

I am going to try the following when I have the chance:

Shut downports to only use 1 fibre uplink in the the etherchannels and if this makes no difference break the etherchannel in totality to rule it out. I am yet to confirm if there are issues when connected to the 10.80.5.104 3560 switch on the 11th floor.

I hope this makes the situation a little clearer.

Thanks

Richard

New Member

Re: Slow network performance across Etherchannel

OK - I see where STP comes into it now. Are there performance issues for all users on teh 12th floor or only for users on a certain switch??

Thanks,

Neil

New Member

Re: Slow network performance across Etherchannel

I have a desktop engineer on site investigating and the information returned is that all users have the issue. I have asked him to identify if there is an issue when connected to the 3560 on the 11th floor.

IOS being used is 12.2 (40) so is not very old at all.

Thanks

Richard

New Member

Re: Slow network performance across Etherchannel

You could check all the ethercahnnel links into the core and make sure there are no duplex mis-matches. It sounds like it could be something like that??

If the performance issues are on all 3 switches it's a bit wierd because the floor12_1 and floor12_2 switches are only connected to each other via the core which would suggest it's either the core itself or the fibre runs??

Interference on the fibre cables??

Neil

New Member

Re: Slow network performance across Etherchannel

All duplex settings are 1000 full so no issues here. I think i'm going to break the etherchannel to see what happens next.

Purple

Re: Slow network performance across Etherchannel

Can you post the etherchannel configs for each end and if it is a trunk also post that for each end . If you have forced on the port channel its possible to have a misconfiguration somewhere , where if it is setup as a negotiated channel it would not allow a misconfig . The configs would help .

New Member

Re: Slow network performance across Etherchannel

Hello - the config below is the example for one of the etherchannels to the 3560 switches.

**********************************************************

Cisco 3750 10.80.5.100

**********************************************************

interface Port-channel1

description *** Uplink to LIVERPOOL_3560_12FLoor_1 ***

switchport trunk encapsulation dot1q

switchport mode trunk

!

!

interface GigabitEthernet1/0/25

description *** Uplink to LIVERPOOL_3560_12Floor_1 ***

switchport trunk encapsulation dot1q

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust dscp

auto qos voip trust

channel-group 1 mode on

!

interface GigabitEthernet1/0/27

description *** Uplink to LIVERPOOL_3560_12Floor_1 ***

switchport trunk encapsulation dot1q

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust dscp

auto qos voip trust

channel-group 1 mode on

!

**********************************************************

Cisco 3560 10.80.5.101

**********************************************************

interface Port-channel1

description *** Uplink to LIVERPOOL_3750_Comms_1 ***

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/1

description *** Uplink to LIVERPOOL_3750_Comms_1 ***

switchport trunk encapsulation dot1q

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust dscp

auto qos voip trust

channel-group 1 mode on

!

interface GigabitEthernet0/3

description *** Uplink to LIVERPOOL_3750_Comms_1 ***

switchport trunk encapsulation dot1q

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust dscp

auto qos voip trust

channel-group 1 mode on

1069
Views
0
Helpful
8
Replies