Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

smart serial connection not working between 2600 series routers

I have a smart serial cable connected between R2 and R3 and it is up/down. I have tried switching the dce to the other router but nothing. when I type no shut it comes up/up for about 20-30 seconds then goes to up/down. Tested 3 different cables both ends. The R1 to R2 connection came right up when connected. I am not sure if I have a bad wic card or something in the config. Any help with this would be greatly appreciated.

R3#show controllers se0/1

Interface Serial0/1

Hardware is PowerQUICC MPC860

DCE V.35, clock rate 56000

idb at 0x82C19B18, driver data structure at 0x82C1C4EC

SCC Registers:

General [GSMR]=0x2:0x00000030, Protocol-specific [PSMR]=0x8

Events [SCCE]=0x0000, Mask [SCCM]=0x001F, Status [SCCS]=0x03

Transmit on Demand [TODR]=0x0, Data Sync [DSR]=0x7E7E

Interrupt Registers:

Config [CICR]=0x00367F80, Pending [CIPR]=0x00000200

Mask   [CIMR]=0x30200440, In-srv  [CISR]=0x00000000

Command register [CR]=0x680

Port A [PADIR]=0x4400, [PAPAR]=0xFFFF

       [PAODR]=0x0000, [PADAT]=0x9BDF

Port B [PBDIR]=0x0630F, [PBPAR]=0x0000E

       [PBODR]=0x00000, [PBDAT]=0x39CED

Port C [PCDIR]=0x00C, [PCPAR]=0x000

       [PCSO]=0x280,  [PCDAT]=0xCF2, [PCINT]=0x00F

Receive Ring

        rmd(68012930): status 9000 length 60C address 3C6CDC4

        rmd(68012938): status B000 length 60C address 3C6C744

Transmit Ring

        tmd(680129F0): status 5C00 length 18 address 3C00354

R2#show controllers se0/0

Interface Serial0/0

Hardware is PowerQUICC MPC860

DTE V.35 clocks stopped.

idb at 0x80F93B58, driver data structure at 0x80F966F0

SCC Registers:

General [GSMR]=0x2:0x00000030, Protocol-specific [PSMR]=0x8

Events [SCCE]=0x0000, Mask [SCCM]=0x001F, Status [SCCS]=0x02

Transmit on Demand [TODR]=0x0, Data Sync [DSR]=0x7E7E

Interrupt Registers:

Config [CICR]=0x00367F80, Pending [CIPR]=0x00000A00

Mask   [CIMR]=0x30200440, In-srv  [CISR]=0x00000000

Command register [CR]=0x640

Port A [PADIR]=0x4000, [PAPAR]=0xFFFF

       [PAODR]=0x0000, [PADAT]=0xF9EB

Port B [PBDIR]=0x0630F, [PBPAR]=0x0900E

       [PBODR]=0x0000E, [PBDAT]=0x30CCD

Port C [PCDIR]=0x00C, [PCPAR]=0x000

       [PCSO]=0x280,  [PCDAT]=0xC30, [PCINT]=0x00F

Receive Ring

        rmd(68012930): status 9000 length 60C address 1C93EA4

        rmd(68012938): status B000 length 60C address 1C94524

Transmit Ring

        tmd(680129B0): status DC00 length 18 address 1D80654

R2(config-if)#shut

R2(config-if)#no shut

R2(config-if)#

16:23:59: %LINK-5-CHANGED: Interface Serial0/0, changed state to administratively down

R2(config-if)#

16:24:02: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up

16:24:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up

R2(config-if)#

16:24:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down

4 REPLIES
Hall of Fame Super Silver

smart serial connection not working between 2600 series routers

When I see a problem with serial interfaces being up/down frequently one of my first thoughts is to wonder about whether clock has been specified. I am glad to see the output of show controller does indicate that one router is DCE with a clock rate. So this is not the problem. Perhaps you could also post the configuration from both routers?

HTH

Rick

New Member

smart serial connection not working between 2600 series routers

R2#show run

Building configuration...

Current configuration : 599 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R2

!

!

ip subnet-zero

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.2.1 255.255.255.128

speed 100

full-duplex

!

interface Serial0/0

ip address 10.1.1.2 255.255.255.252

!

interface Serial0/1

ip address 10.1.1.5 255.255.255.252

clockrate 125000

!

ip classless

ip http server

ip pim bidir-enable

!

!

line con 0

exec-timeout 0 0

password cisco

logging synchronous

login

line aux 0

line vty 0 4

exec-timeout 0 0

password cisco

logging synchronous

login

!

end

R3#show run

Building configuration...

Current configuration : 760 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R3

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

ip cef

!

!

!

ip audit po max-events 100

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.2.129 255.255.255.128

speed 100

full-duplex

!

interface Serial0/0

no ip address

!

interface FastEthernet0/1

no ip address

speed 100

full-duplex

!

interface Serial0/1

ip address 10.1.1.1 255.255.255.252

clock rate 56000

!

ip http server

no ip http secure-server

ip classless

!

!

!

!

!

!

!

!

line con 0

exec-timeout 0 0

password cisco

logging synchronous

login

line aux 0

line vty 0 4

password cisco

login

!

!

end

VIP Super Bronze

smart serial connection not working between 2600 series routers

Al though this is default, but under each interface can you add:

encap hdlc

also, on R2,

R2#show controllers se0/0

Interface Serial0/0

Hardware is PowerQUICC MPC860

DTE V.35 clocks stopped

So, since r1 and r2 are working fine, can you check the show controller and see if you see the same message on DTE router?

HTH

New Member

smart serial connection not working between 2600 series routers

As requesed i added encap hdlc to both sides. There is a difference on the dte end on R1.

R2#show controllers se0/1

Interface Serial0/1

Hardware is PowerQUICC MPC860

DCE V.35, clock rate 125000

idb at 0x80F97F3C, driver data structure at 0x80F9ACB0

SCC Registers:

General [GSMR]=0x2:0x00000030, Protocol-specific [PSMR]=0x8

Events [SCCE]=0x0000, Mask [SCCM]=0x001F, Status [SCCS]=0x06

Transmit on Demand [TODR]=0x0, Data Sync [DSR]=0x7E7E

Interrupt Registers:

Config [CICR]=0x00367F80, Pending [CIPR]=0x00000A00

Mask   [CIMR]=0x30200440, In-srv  [CISR]=0x00000000

Command register [CR]=0x640

Port A [PADIR]=0x4000, [PAPAR]=0xFFFF

       [PAODR]=0x0000, [PADAT]=0xF9FF

Port B [PBDIR]=0x0630F, [PBPAR]=0x0900E

       [PBODR]=0x0000E, [PBDAT]=0x30CCD

Port C [PCDIR]=0x00C, [PCPAR]=0x000

       [PCSO]=0x280,  [PCDAT]=0xC30, [PCINT]=0x00F

Receive Ring

        rmd(68012A30): status 9000 length 1A address 1D7FE44

        rmd(68012A38): status B000 length 1A address 1D7F144

Transmit Ring

        tmd(68012AB0): status 5C00 length 18 address 1D80654

R1#show controllers se0/0

Interface Serial0/0

Hardware is PowerQUICC MPC860

DTE V.35 TX and RX clocks detected.

idb at 0x81F76008, driver data structure at 0x81F7899C

SCC Registers:

General [GSMR]=0x2:0x00000030, Protocol-specific [PSMR]=0x8

Events [SCCE]=0x0000, Mask [SCCM]=0x001F, Status [SCCS]=0x06

Transmit on Demand [TODR]=0x0, Data Sync [DSR]=0x7E7E

Interrupt Registers:

Config [CICR]=0x00367F80, Pending [CIPR]=0x00000800

Mask   [CIMR]=0x20200400, In-srv  [CISR]=0x00000000

Command register [CR]=0x640

Port A [PADIR]=0x4000, [PAPAR]=0xFFFF

       [PAODR]=0x0000, [PADAT]=0xFFF3

Port B [PBDIR]=0x0630F, [PBPAR]=0x0400E

       [PBODR]=0x0000E, [PBDAT]=0x3DDDD

Port C [PCDIR]=0x00C, [PCPAR]=0x000

       [PCSO]=0x380,  [PCDAT]=0xF30, [PCINT]=0x00F

Receive Ring

        rmd(680127F0): status 9000 length 2E address 2DB4FC4

        rmd(680127F8): status B000 length 30 address 2DB5644

Transmit Ring

        tmd(680128B0): status 5C00 length 2F address 2DDE8F4

--More--

268
Views
10
Helpful
4
Replies
CreatePlease login to create content