Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

SOHO91 NAT not working.

I am trying to Nat. I am not getting translations. Its connected to Cable modem and I and ping www.yahoo.com and WAN IP addresses from IOS. Why is NAT not working? DHCP is working and DNS is correct getting it from Cable modem.

Router Model : SOHO91

IOS Image Name : soho91-k9oy6-mz.123-2.XC2.bin

IOS Version : 12.3(2)XC2

Number of Telnet connection(s) : 1

Router Up Time : 19 minutes

Building configuration...

Current configuration : 1198 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Petaluma

!

no logging buffered

enable secret 5 <removed>

enable password <removed>

!

username CRWS_Bijoy privilege 15 password 0 <removed>

username CRWS_Jaidil privilege 15 password 0 <removed>

no aaa new-model

ip subnet-zero

no ip routing

ip name-server 68.87.76.178

ip name-server 68.87.78.130

ip dhcp excluded-address 192.168.0.1

!

ip dhcp pool CLIENT

import all

network 192.168.0.0 255.255.255.0

default-router 192.168.0.1

lease 0 2

!

!

!

!

!

!

!

!

!

interface Ethernet0

ip address 192.168.0.1 255.255.255.0

ip nat inside

no ip route-cache

no cdp enable

hold-queue 32 in

!

interface Ethernet1

ip address dhcp client-id Ethernet1

ip nat outside

no ip route-cache

duplex auto

no cdp enable

!

ip nat inside source list 102 interface Ethernet1 overload

ip classless

ip http server

no ip http secure-server

!

access-list 102 permit ip 192.168.0.0 0.0.0.255 any

no cdp run

!

line con 0

no modem enable

line aux 0

line vty 0 4

exec-timeout 120 0

password <removed>

login local

length 0

!

scheduler max-task-time 5000

!

end

Petaluma#sh ip nat statistics

Total active translations: 0 (0 static, 0 dynamic; 0 extended)

Outside interfaces:

Ethernet1

Inside interfaces:

Ethernet0

Hits: 0 Misses: 0

Expired translations: 0

Dynamic mappings:

-- Inside Source

[Id: 1] access-list 102 interface Ethernet1 refcount 0

Petaluma#sh ip nat translations

Petaluma#

4 REPLIES

Re: SOHO91 NAT not working.

Hi

ip routing is disabled.enable it and try.

router(config)#ip routing

Thanks

Mahmood

New Member

Re: SOHO91 NAT not working.

Oh my! I'ts been a while since I configured a router. That worked.

Thanks!

Re: SOHO91 NAT not working.

why it is disabled is it by default in the router ?

New Member

Re: SOHO91 NAT not working.

Yes its disabled by default it seems. I did a erase Nvram:. The wierd thing is I used the built in GUI and configured it for use with cable modem. That must really drive a lot of people nuts!

124
Views
0
Helpful
4
Replies