Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

[SOLVED] cat6500 vlan filtering not working

Hello!

I have cat 6500 with SUP32-GE-3B/MSFC2A/PFC3B, s3223-adventerprisek9-mz.122-33.SXJ6.bin,

and WS-X6148-GE-TX module.

And I have a couple of 3750G.

On all of 3750G there is a broadcast filtering of VLAN 4000, and it's working:

mac access-list extended badhosts
  permit any host ffff.ffff.ffff

vlan access-map dropbad 10
  action drop
  match mac address badhosts
vlan access-map dropbad 20
  action forward

vlan filter dropbad vlan-list 4000


Then i copy this config to 6500, and it's not working.  I configured two ports, one is switchport access vlan 4000 and other is switchport capture allowed vlan 4000, and i see on both ports same broadcast traffic. Filter is working, but packets are not dropping. I've tried to find something in manual, but found only about platform cwan acl software-switched, enabled it, nothing changed.

 

cat6500# sh vlan filter
VLAN Map dropbad:
        Configured on VLANs:  4000
            Active on VLANs:  4000

Everyone's tags (1)
1 REPLY
New Member

i think i solve the problem:

i think i solve the problem: to make vlan filtering to work on 6500, i've added:

 

# conf t
(config)# int vlan 4000
(config-if)# no shut
(config-if)# mac packet-classify

 

Now, how to mark this question answered?

20
Views
0
Helpful
1
Replies