Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Some clients can't communicate with secondary IP subnet

I have an issue that's been bugging me since this morning. This site has a single VLAN, 1, and the gateway is an SVI for VLAN 1 with a secondary IP of 192.168.116.254/24 and a primary IP of 10.53.16.1/22.

Some clients on the 10 network can ping servers on the 192 network, but some cannot. From the switches, I can ping the servers at 192.168.116.64 and .80. The servers and most of the clients are connected to the same switch stack, but still can't talk. I have attached a diagram and the interface configs are below. There are no ACLs on any of the switches either.

 

4500X

interface Vlan1
 description GATEWAY FOR LAN
 ip address 192.168.116.254 255.255.255.0 secondary
 ip address 10.53.16.1 255.255.252.0

interface TenGigabitEthernet1/1/3
 switchport mode trunk
 channel-group 1 mode active

interface TenGigabitEthernet2/1/3
 switchport mode trunk
 channel-group 1 mode active

interface Port-channel1
 switchport
 switchport mode trunk

 

 

3850 Stack

interface Vlan1
 ip address 10.53.16.5 255.255.252.0

interface GigabitEthernet1/1/1
 switchport mode trunk
 channel-group 1 mode active

interface GigabitEthernet4/1/1
 switchport mode trunk
 channel-group 1 mode active

interface Port-channel1
 switchport mode trunk

 

Everyone's tags (1)
5 REPLIES

Hello, Can you try to do a

Hello,

 

Can you try to do a ping from one PC to a server that does not work and check if with wireshark you see the packets reaching the server?

Have you make sure all of the PCs have the right Default gateway on their corresponding VLAN?

 

Do you see the ARP mapping on their network table?

 

Regards

Looking for some Networking Assistance? Contact me directly at jcarvaja@laguiadelnetworking.com I will fix your problem ASAP. Cheers, Julio Carvajal Segura http://laguiadelnetworking.com
New Member

I have not done a packet

I have not done a packet capture yet.

Yes, the PCs have the correct default gateway, they all point to the 4500s.

Yes, both the client and servers are in the ARP tables of the 4500s.

New Member

Regarding the PCs that do not

Regarding the PCs that do not reach the servers, can they ping the other VLAN1 ip address, i.e. the one other than their gateway address?

New Member

Can you share a traceroute

Can you share a traceroute for different subnets from the clients subnet(s) ?

 

 

Hall of Fame Super Silver

Two things in the partial

Two things in the partial config shown puzzle me though I am not sure if either is really the problem.

- the original post says there is only a single vlan. but the connection between switches is configured as a trunk? why is there a trunk if there is only a single vlan?

- the 4500 has the primary and secondary addresses but the 3850 has only the primary address. I wonder what would happen if the secondary address were configured on the 3850 also?

 

HTH

 

Rick

434
Views
0
Helpful
5
Replies