Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Some trunks are connected at 100Mbps

I have C3750E as a coreswitch and C2960G as access swtiches. All switches are connected to coreswtich using CAT6 cable and interface is configured as trunk. When I check the interface status on coreswitch I can see some of the trunk lines are connected at 100Mbps. All switches are having same trunk configuration.

Port            Name      Status       Vlan       Duplex  Speed  Type

Gi1/0/5    FLOOR5    connected    trunk      a-full    a-1000 10/100/1000BaseTX

Gi1/0/13  FLOOR4    connected    trunk      a-full    a-100   10/100/1000BaseTX

Gi1/0/15  FLOOR6    connected    trunk      a-full    a-100   10/100/1000BaseTX

Gi1/0/16  FLOOR1    connected    trunk      a-full    a-100   10/100/1000BaseTX

Gi1/0/17  FLOOR7    connected    trunk      a-full    a-1000 10/100/1000BaseTX

Gi1/0/19  FLOOR8    connected    trunk      a-full    a-100   10/100/1000BaseTX

Anyone have any idea why some of the lines are connected at 100Mbps?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Some trunks are connected at 100Mbps

Hi Ismail,

From the below output.

0009: 0C00 1000BASE-T Control Register           :  0000 1100 0000 0000

000A: 4000 1000BASE-T Status Register            :  0100 0000 0000 0000

And on 2960 I get 3 register pages

Page 0 Registers

------------------------------

0009: 0F00 1000BASE-T Control Register           :  0000 1111 0000 0000

000A: 4000 1000BASE-T Status Register            :  0100 0000 0000 0000

I strongly believe the issue is on 3750, try reseating the cable on the 3750 end. Incase, if you have any patch-panel please try to exclude that as well to check the status.

Thanks

Karthick Murugan

Thanks & Regards, Karthick Murugan CCIE#39285
6 REPLIES
Cisco Employee

Re: Some trunks are connected at 100Mbps

Hi Ismail,

Most of the time it could be because the hardware register might not have set properly. Please check the output of the following

show controllers ethernet-controller phy detail | be 1/0/13 and check for register value 9 and 10.

Example:
0009: 0F00 1000BASE-T Control Register : 0000 1111 0000 0000
                                                --
000A: 3C00 1000BASE-T Status Register : 0011 1100 0000 0000
                                             --
From this looking at bit 9 and bit 8 on the register 9. Here bit 8 and 9 is set to 11 which means 2960 will advertise itself as 1000 with full duplex. On looking at register 10 we should be looking into the bit 10 and 11. Here both the bits are set (11). Hence 2960 thinks the 6500 has advertised it to be 1000 full capable. Perform the same on 3750 as well and find the problematic switch.Most of the time reseating the cable will resolve the issue.

Thanks & regards,
Karthick Murugan



Thanks & Regards, Karthick Murugan CCIE#39285
New Member

Re: Some trunks are connected at 100Mbps

Hi Karthick,

Thanks for your reply.

This is what I get form 3750

0009: 0C00 1000BASE-T Control Register           :  0000 1100 0000 0000

000A: 4000 1000BASE-T Status Register            :  0100 0000 0000 0000

And on 2960 I get 3 register pages

Page 0 Registers

------------------------------

0009: 0F00 1000BASE-T Control Register           :  0000 1111 0000 0000

000A: 4000 1000BASE-T Status Register            :  0100 0000 0000 0000

Page 1 Registers

------------------------------

0009: 0000 1000BASE-T Control Register           :  0000 0000 0000 0000

000A: 0000 1000BASE-T Status Register            :  0000 0000 0000 0000

Page 2 Registers

------------------------------

0009: 0000 1000BASE-T Control Register           :  0000 0000 0000 0000

000A: 0000 1000BASE-T Status Register            :  0000 0000 0000 0000

Thanks

Cisco Employee

Re: Some trunks are connected at 100Mbps

Hi Ismail,

From the below output.

0009: 0C00 1000BASE-T Control Register           :  0000 1100 0000 0000

000A: 4000 1000BASE-T Status Register            :  0100 0000 0000 0000

And on 2960 I get 3 register pages

Page 0 Registers

------------------------------

0009: 0F00 1000BASE-T Control Register           :  0000 1111 0000 0000

000A: 4000 1000BASE-T Status Register            :  0100 0000 0000 0000

I strongly believe the issue is on 3750, try reseating the cable on the 3750 end. Incase, if you have any patch-panel please try to exclude that as well to check the status.

Thanks

Karthick Murugan

Thanks & Regards, Karthick Murugan CCIE#39285
New Member

Some trunks are connected at 100Mbps

Thanks Karthick, It was the patch-panel issue. Now I have fixed it.

Thanks Leo for the TDR tip. It was really helpful.

Re:Some trunks are connected at 100Mbps

Hi
I suggest to check the cable as all 4 pairs need to be terminated properly in order to het 1 gig

Thanks

Sent from Cisco Technical Support Android App

Hall of Fame Super Gold

Some trunks are connected at 100Mbps

I'd check your configuration to make sure you don't have an interface configuration that goes like "speed auto 10 100".

Next, I'd check your cable pair using TDR which both the 3750E and the 2960G supports.

210
Views
0
Helpful
6
Replies
CreatePlease to create content