Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Spanned Vlans failed, routing still working on same ports!

This is a very strange problem that I have. We have a site in which is connected to two other sites via BT Les 100 lines (dark fibre effectively). Last week the switches in one site just stopped any spanned vlan's working across the data links.

The links are still operational and all layer 3 trafic is running as normal - we just haven't got any layer 2 traffic.

Nothing was changed on the switches (in fact there weren't any network engineers on site) or the routers but the spanned vlans just stopped. rebooting the switches didn't make any difference either.

The switches are 3750 stack units running ios 12.1(19) which I know is out of date but they have been running quietly for the last 3 years without a problem.

Any suggestions - I am going to replace them with a 4507 in the next week or so anyway but was just curious as to the fault.

Thanks

Giles

5 REPLIES
Hall of Fame Super Bronze

Re: Spanned Vlans failed, routing still working on same ports!

Are the inter-switch links configured as trunk or access switchports ?

Can we see the portion of the config from either end ?

Community Member

Re: Spanned Vlans failed, routing still working on same ports!

Network Configuration from "working" end

interface FastEthernet3/19

description LES100 to TRE-SWST1 Fa1/0/48

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-3,5-7,9,600,634

switchport mode trunk

speed 100

duplex full

qos trust dscp

auto qos voip trust

tx-queue 3

bandwidth percent 10

priority high

shape percent 30

service-policy output autoqos-voip-policy

end

Networ Configuration from "faulty" end.

interface FastEthernet1/0/48

description *** Trunk to BRE-IerE3-CORE01 Fa3/19 (LES100) ***

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-3,5-7,9,634

switchport mode trunk

no ip address

duplex full

speed 100

srr-queue bandwidth share 10 10 60 20

priority-queue out

mls qos trust dscp

no mdix auto

end

Both ends of the link are still operational for routing just not for trunk links.

As you can see both ends are configured as trunk links running the same encapsulation.

The strange thing is that the link just failed after 3 years of normal operation.

Giles

Community Member

Re: Spanned Vlans failed, routing still working on same ports!

Update on this problem.

Last night we swapped the "faulty" switch for the new 4500 I had previously prepared. We still have the same problem with layer 2 traffic not traversing the links.

the new configuration from the core is as follows:

interface GigabitEthernet3/19

description *** Trunk to BRE-IerE3-CORE01 Fa3/19 (LES100) ***

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-3,5-7,9,600,634

switchport mode trunk

speed 100

duplex full

qos trust cos

tx-queue 3

bandwidth percent 10

priority high

shape percent 15

end

Purple

Re: Spanned Vlans failed, routing still working on same ports!

Can you post a show vlan for both sides and a show int trunk from both sides . Any reason why vlan 600 is missing on one side ? Check to see your native vlan matches on both sides , I think a show int switchport will give you that info .

Community Member

Re: Spanned Vlans failed, routing still working on same ports!

Finally fixed the problem.

It was certainly obscure - one of the wide area links had suffered a partial failure. It was no longer handling traffic but staying live enough to keep the spanning-tree in check. As a result of this the routing was working through the other link but the latyer 2 traffic didn't fail over.

The link has now been repaired and is working as designed again.

Giles

341
Views
0
Helpful
5
Replies
CreatePlease to create content