Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Spanning Tree and VLAN with c3650

Hello,

I would like some help on configuring two C3650 for spanning tree between two VLAN.

Here is the goal :

Having two operator LAN to LAN connections between two Data Centers to have some redundancy.

For connecting the two data centers with each other, we have two C3560 (one on each side).

We would like to allocate a vlan of at least 8 ports for each connection and have spanning tree for being able to switch on the other connection if one was down...

Is this possible ?

Can you give me some info about the possible configs ?

Best Regards,

Patrice.

3 REPLIES
Hall of Fame Super Blue

Re: Spanning Tree and VLAN with c3650

Patrice

If i understand correctly you have a switch at either end and you want to use 8 ports on each switch for the connection. If so you would be better creating an etherchannel between the 2 switches and then STP will see the etherchannel as one link and will not block -

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_44_se/configuration/guide/swethchl.html

Jon

Community Member

Re: Spanning Tree and VLAN with c3650

In the doc posted by Jon, you can see that 8 is the maximun active ports, but you can do load balancing forcing STP to elect one port as root port for some VLANs and the other for the rest.

This is an example

spanning-tree mode rapid-pvst

interface range GigabitEthernet1/0/1 -8

description ECh_A

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

spanning-tree vlan 20,21,22 port-priority 16

interface range GigabitEthernet1/0/9 - 17

description ECh_B

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 2 mode active

spanning-tree vlan 23-25 port-priority 16

spanning-tree vlan vlan-id port-priority priority

For priority, the range is 0 to 240, in increments of 16; the default is 128.

All other values are rejected. The lower the number, the higher the priority.


Guido.

Please rate all the helpful comments.

Community Member

Re: Spanning Tree and VLAN with c3650

Hi Jon,

It seems that you haven't completely understood, maybe I haven't explicated very well... :)

BUT the Etherchannel is responding to my problem anyway.

At first we had the idea not to use an etherchannel but something like 2 virtual switches inside the C3560 at each site which are connected with two operator LAN to LAN...

We are currently using only one switch where we should use two to be fully redundant (even at hardware level).

Since we have only one switch the etherchannel solution is as good as using virtual switching for us.

Thank you very much.

Best Regards.

Patrice.

252
Views
0
Helpful
3
Replies
CreatePlease to create content