Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Spanning Tree between Cisco and ALU Switches

Hi

Bit off topic.

I'm getting a unusual spanning-tree behaviour between a Cisco 3560 and a ALU 6850 switch.

I have rapid spanning tree set up on the ALU and Rapid-pvst on the Cisco. A few vlan's configured across a dot1q trunk.

The ALU is set with the lowest bridge priority, however both switches on all vlan's see them selves as root. With no change in the priority field.

It appears that 802.1w and Rapid-PVST are not compatible in this instance?

Any ideas? config samples if you have done this before.

Thanks in advanced

3 REPLIES

Re: Spanning Tree between Cisco and ALU Switches

Hi Gareth

>>It appears that 802.1w and Rapid-PVST are not compatible in this instance?

Correct, rapid-pvst is Cisco proprietary. You should see the correct root bridge on vlan 1 but not on the other vlans

Your best solution is MST if both sides support it

Simon

New Member

Re: Spanning Tree between Cisco and ALU Switches

Thanks Simon

Been playing with it the last hour.

Funny enough, when you place a redundant link in the mix, no changes on the bridge root, but the cisco does block the ports to stop the loop.

If any body else has any ideas, would be much appreciated.

Re: Spanning Tree between Cisco and ALU Switches

Hi Gareth.

That is because rapid-pvst+ uses the Cisco Shared Spanning Tree (SSTP) multicast mac 01-00-0C-CC-CC-CD for it's BPDUs on all VLANs besides VLAN 1. The non Cisco switches flood these and that is how the Cisco switches learn of a loop condition

Simon

900
Views
4
Helpful
3
Replies
CreatePlease to create content