Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Bronze

Spanning tree load balancing

Dear Experts ,

I have two switches connected through two wirelesss links as given below . I want to put all upload traffic through one link and download traffic through other link as given below


SW1 (Fa0/40)---<<<<---link2---<<<<---SW2(Fa0/24)
SW2 (Fa0/46)--->>>----link1--->>>----SW2(Gi0/2)

I applied the below config. But it seems to be not working .Is there is anything else I can do with configuration


SW1 config

interface FastEthernet0/40
description LINK2
switchport mode trunk
spanning-tree vlan 1-1024 port-priority 16
spanning-tree vlan 1-1024 cost 100
end

sh run int f0/46
Building configuration...

interface FastEthernet0/46
description "LINK1"
switchport mode trunk
spanning-tree vlan 1-1024 port-priority 32
spanning-tree vlan 1-1024 cost 50
end

SW2 config

interface FastEthernet0/24
description LINK2
switchport mode trunk
spanning-tree vlan 1-1024 port-priority 32
spanning-tree vlan 1-1024 cost 50

interface GigabitEthernet0/2
description LINK1
switchport mode trunk
spanning-tree vlan 1-1024 port-priority 16
spanning-tree vlan 1-1024 cost 100

1 REPLY
Cisco Employee

Re: Spanning tree load balancing

Hello Haris,

What you want to do cannot be done using Spanning Tree Protocol, and it is not a good idea anyway.

If a port is in the STP Forwarding state then it is open for both directions - incoming and outgoing traffic. The STP does not consider the direction of data flow when computing the spanning tree, and has no provisions for doing that. Thus, a spanning tree created by the STP is used to convey data in both directions.

Moreover, your idea of having an upstream traffic going through a different link than the downstream traffic goes against the logic of Ethernet frame switching. If an upstream frame arrives on a port A, the switch will learn the source MAC of this frame and ascribe it to the port A. When a reply arrives, the switch will forward the reply out the port A because that is where the original source is connected. Note that this even does not have anything to do with the STP at all.

Forcing a traffic to go different path in upstream direction and different path in downstream direction in a switched topology could also cause unnecessary flooding of unicast traffic. If a bidirectional data flow does not pass the same devices and links in the topology, switches are unable to learn the location of the destination MACs, resulting in flooding the unicast streams, which is certainly something we do not want to see.

Best regards,

Peter

536
Views
0
Helpful
1
Replies