Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Spanning-tree portfast trunk question

In doing my CCNP switching studies I am going over some of our configurations of our switches and I came across something I have a question on with Spanning Tree.

I have attached a small diagram of how the switches are connected.

Here are the configs for the two switches, I know there is a MTU mismatch and I will be correcting that, not sure how that happened. The question I have is the use of the command…. spanning-tree portfast trunk

Should it stay that way, and is it doing anything for me? Should I maybe use Uplinkfast instead?

Configuration on Core Switch (Catalyst 6509 running VSS)

interface Port-channel104
description 4th Floor EtherChannel
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
mtu 9216
spanning-tree portfast trunk

interface GigabitEthernet1/3/37
description 4th Floor Ether-Channel
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
mtu 9216
channel-group 104 mode on
spanning-tree portfast trunk

interface GigabitEthernet2/3/37
description 4th Floor Ether-Channel
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
mtu 9216
channel-group 104 mode on
spanning-tree portfast trunk

*************************************************************************

Configuration on IDF Access switch (Catalyst 4506)

interface Port-channel4
description 4th Floor EtherChannel
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
mtu 9198
spanning-tree portfast trunk

interface GigabitEthernet1/3
description Ether-Channel to Core
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
mtu 9198
channel-group 4 mode on
spanning-tree portfast trunk

interface GigabitEthernet1/4
description Ether-Channel to Core
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
mtu 9198
channel-group 4 mode on
spanning-tree portfast trunk

Thanks,

Mike

12 REPLIES
Hall of Fame Super Blue

Re: Spanning-tree portfast trunk question

Mike

Spanning-tree portfast trunk should never be used on switch interconnects because with switch interconnects you want STP to make sure there is no loop before forwarding.

The command is really designed for servers which are running 802.1q on their NICs and which can transition to forwarding immediately.

Jon

Hall of Fame Super Silver

Re: Spanning-tree portfast trunk question

Hello Mike,

here we have an example of the advantages that can be provided by using a VSS pair.

Without VSS you would have used two separate links one to each C6500 and you would not have used that command for network safety in case of problems you would stay with standard timers.

Here you have the two links used as a single bundle and they are treated as a single link by STP, this allows to use the command.

Removing the command would add in safety specially if you are not using Rapid STP or MST but you are in PVST+ at the price of slower convergence.

If you are using Rapid PVST or MST the command is not needed at all; there is the handshake on the link to handle transitions in a fast and more secure way.

As a final note I would suggest to move to LACP  (mode active) it provides some advantages over using mode on (unconditionally bundling this can cause problems if someone should move a cable by error)

Hope to help

Giuseppe

Hall of Fame Super Blue

Re: Spanning-tree portfast trunk question

Giuseppe

Agreed that VSS is involved so it is seen as one link but in my opinion you should still not use portfast trunk on switch uplinks. STP is still used a failsafe in the background even though VSS is running.

Jon

Hall of Fame Super Silver

Re: Spanning-tree portfast trunk question

Hello Jon,

I agree I would not keep the command.

my first answer may have been too marketing oriented ....

Hope to help

Giuseppe

Re: Spanning-tree portfast trunk question

Thank you both for your responces that help greatly. When I read up on the command I did not think it should be used but like what was stated, it is an etherchannel so it is only one link. I am going to remove the command but should I be aware of anything when I do? Also should or could I use Uplinkfast? or is there no need since it is only one link.

Mike

Re: Spanning-tree portfast trunk question

Giuseppe said....

As a final note I would suggest to move to LACP  (mode active) it provides some advantages over using mode on (unconditionally bundling this can cause problems if someone should move a cable by error)

Can you expain a little more...please.

Mike

Hall of Fame Super Silver

Re: Spanning-tree portfast trunk question

Hello Mike,

with LACP the two devices exchange messages in order to negotiate the bundle and to detect the presence of the other device and that the same device is on the other side in all member links (key point)

if for an error someone moves a cable of an unconditional on bundle and connects it to a third switch you can imagine that a terrible mess with STP is the result.

LACP will suspend a member link if it doesn't hear LACP messages from neighbor and in this way it helps in dealing with this kind of errors.

For this reason I changed my mind and now I prefer and suggest LACP also for bundles between switches not only towards servers.

Hope to help

Giuseppe

Re: Spanning-tree portfast trunk question

Gotch ya. So you prefer LACP over PaGP for that reason. Sound good.

Thanks as always for your help.

Mike

Hall of Fame Super Blue

Re: Spanning-tree portfast trunk question

burleyman wrote:

Thank you both for your responces that help greatly. When I read up on the command I did not think it should be used but like what was stated, it is an etherchannel so it is only one link. I am going to remove the command but should I be aware of anything when I do? Also should or could I use Uplinkfast? or is there no need since it is only one link.

Mike

Mike

Uplinkfast is no use if you only have one uplink. Note also that if you run RSTP or MST then uplinkfast has been incorporated into those versions of STP.

Jon

Re: Spanning-tree portfast trunk question

Jon,

Thanks for the info. Right now we are running RPVST+. We have a core switch and 6 IDF closet switches that are etherchanneled to the core. We have 70 different VLAN's which means 70+ STP instances. Would looking at going to MST have a great benefit or should i leave well enough alone?

Thanks,

Mike

Hall of Fame Super Blue

Re: Spanning-tree portfast trunk question

Mike

Never used MST to be honest. If your switches are okay in terms of CPU/memory usage and you are not getting close to the STP limit on any switch i would stick with RSTP if i was you. Also bear in mind that you don't necessarily need all 70 vlans on every switch so using the "switchport trunk vlan allowed ..." command on trunks will limit STP instances running across every switch.

Jon

Re: Spanning-tree portfast trunk question

Thanks Jon,

I was looking into doing that with the VLAN's allowed. Thanks for all your input...learning is fun.

Mike

24387
Views
35
Helpful
12
Replies
CreatePlease to create content