Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

spanning tree problem

Hi,

there is a iscsi storage device stat is connected to g0/39 and G0/40 switch which is running rapid PVST.

port configuration is below.

Even though there is bpdu guard, port is becoming designated. What should be the problem?

!

interface GigabitEthernet1/39

description SVCGM_A(2)

switchport access vlan 111

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

end


1#sh run int g1/40

Building configuration...


Current configuration : 169 bytes

!

interface GigabitEthernet1/40

description SVCGM_C(2)

switchport access vlan 111

switchport mode access

spanning-tree portfast

spanning-tree bpduguard enable

end



----------------------------------------------------------------------



447322: 4y5w: RSTP(111): initializing port Gi1/39

447323: 4y5w: RSTP(111): Gi1/39 is now designated

447324: 4y5w: RSTP(111): initializing port Gi1/39

447325: 4y5w: RSTP(111): Gi1/39 is now designated

447326: 4y5w: RSTP(111): initializing port Gi1/39

447327: 4y5w: RSTP(111): Gi1/39 is now designated

447328: 4y5w: RSTP(111): initializing port Gi1/39

447329: 4y5w: RSTP(111): Gi1/39 is now designated

447330: 4y5w: RSTP(111): initializing port Gi1/39

447331: 4y5w: RSTP(111): Gi1/39 is now designated

447332: 4y5w: RSTP(111): initializing port Gi1/39

447333: 4y5w: RSTP(111): Gi1/39 is now designated

447334: 4y5w: RSTP(111): initializing port Gi1/39

447335: 4y5w: RSTP(111): Gi1/39 is now designated

447336: 4y5w: RSTP(111): initializing port Gi1/39

447337: 4y5w: RSTP(111): Gi1/39 is now designated

447338: 4y5w: RSTP(111): initializing port Gi1/39

447339: 4y5w: RSTP(111): Gi1/39 is now designated

447340: 4y5w: RSTP(111): initializing port Gi1/39

447341: 4y5w: RSTP(111): Gi1/39 is now designated

447342: 4y5w: RSTP(111): initializing port Gi1/39

447343: 4y5w: RSTP(111): Gi1/39 is now designated

447344: 4y5w: RSTP(111): initializing port Gi1/39

447345: 4y5w: RSTP(111): Gi1/39 is now designated

447346: 4y5w: RSTP(111): initializing port Gi1/40

447347: 4y5w: RSTP(111): Gi1/40 is now designated

447348: 4y5w: RSTP(111): initializing port Gi1/40

447349: 4y5w: RSTP(111): Gi1/40 is now designated

447350: 4y5w: RSTP(111): initializing port Gi1/40

447351: 4y5w: RSTP(111): Gi1/40 is now designated

447352: 4y5w: RSTP(111): initializing port Gi1/40

447353: 4y5w: RSTP(111): Gi1/40 is now designated

447354: 4y5w: RSTP(111): initializing port Gi1/40

447355: 4y5w: RSTP(111): Gi1/40 is now designated

447356: 4y5w: RSTP(111): initializing port Gi1/40

447357: 4y5w: RSTP(111): Gi1/40 is now designated

447358: 4y5w: RSTP(111): initializing port Gi1/40

447359: 4y5w: RSTP(111): Gi1/40 is now designated

447360: 4y5w: RSTP(111): initializing port Gi1/40

447361: 4y5w: RSTP(111): Gi1/40 is now designated

447362: 4y5w: RSTP(111): initializing port Gi1/40

447363: 4y5w: RSTP(111): Gi1/40 is now designated

447364: 4y5w: RSTP(111): initializing port Gi1/40

447365: 4y5w: RSTP(111): Gi1/40 is now designated

447366: 4y5w: RSTP(111): initializing port Gi1/40

447367: 4y5w: RSTP(111): Gi1/40 is now designated

447368: 4y5w: RSTP(111): initializing port Gi1/40

447369: 4y5w: RSTP(111): Gi1/40 is now designated

447370: 4y5w: RSTP(111): initializing port Gi1/40

447371: 4y5w: RSTP(111): Gi1/40 is now designated



*******************************************************************************




SWITCH#sh spanning-tree vlan 111


VLAN0111

  Spanning tree enabled protocol rstp

  Root ID    Priority    8192

             Address     001c.0f66.6c6f

             Cost        2

             Port        49 (TenGigabitEthernet1/49)

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec


  Bridge ID  Priority    32879  (priority 32768 sys-id-ext 111)

             Address     001b.d496.d540

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

             Aging Time 300


Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Gi1/7            Desg FWD 4         128.7    P2p


Gi1/10           Desg FWD 4         128.10   P2p


Gi1/12           Desg FWD 4         128.12   P2p


Gi1/13           Desg FWD 4         128.13   P2p


Gi1/23           Desg FWD 4         128.23   P2p Edge


Gi1/30           Desg FWD 4         128.30   P2p


Gi1/38           Desg FWD 4         128.38   P2p


Gi1/39           Desg FWD 4         128.39   P2p Edge


Gi1/40           Desg FWD 4         128.40   P2p Edge


Te1/49           Root FWD 2         128.49   P2p


Te1/50           Altn BLK 2         128.50   P2p






*********************************************************************************************


SWITCH#sh ver

Cisco IOS Software, Catalyst 4500 L3 Switch Software (cat4500-IPBASEK9-M), Version 12.2(31)SGA1, RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Fri 26-Jan-07 14:35 by kellythw

Image text-base: 0x10000000, data-base: 0x115C5630


ROM: 12.2(31r)SGA

Pod Revision 0, Force Revision 34, Gill Revision 20

4 REPLIES

spanning tree problem

Seems like some bug.

Can you reload the switch and check whether it is still becoming designated port ?

Regards,

Smitesh

New Member

spanning tree problem

we are not able to reload the swtich. it is in production. Do you now any bug id?

spanning tree problem

Is this log continuous? Do you keep getting these messags non stop?

The ports 1/39 and 1/40 should always be Designated Ports, since they both connect to an end device.

Now if for some reason, the root port Te1/49 lost connectivity to the root switch, it would use the alternate port

almost immeidately, which should cause RPVST to start recalculating.

spanning tree problem

No problem here, unless you're experiencing another issue or outage.

BPDUguard simply disables the port if the port receives BPDUs, such as if a switch or other STP-enabled device is connected to it.  The port itself will still participate in spanning-tree, and will be designated for the segments as you are seeing.  In addition, the ports are showing P2P Edge as they should.

The ports will not be root ports, as that would indicate the root bridge can be reached through them.  This should not be the case if you've planned to configure BPDU guard on the ports.

The ports also should not be disabled, as that would prevent traffic from your storage device from being forwarded.

Not sure if I understand what problem you're experiencing.  What are you expecting to see here?

Off-topic:  Are ports Te1/49 and Te1/50 connected to the same upstream switch?

156
Views
0
Helpful
4
Replies