Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

SPANTREE-7-RECV_1Q_NON_TRUNK

Hello,

Have a 48 port 3750 switch that I am connecting to a 24 port 2950. I just want to get the 48 port on net to download firmware. When I do, I get the Spantree error above.

I configure port 48 on the 3750 as this:

interface FastEthernet1/0/48

switchport access vlan 206

switchport trunk encapsulation dot1q

switchport trunk native vlan 206

switchport mode access

and port 13 on the 2950 as this:

interface FastEthernet0/13

switchport access vlan 206

switchport trunk encapsulation dot1q

switchport trunk native vlan 206

switchport mode access

switchport voice vlan 207

switchport priority extend trust

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

(I turned off the port-fast to in order to see if that was it)

If I did not want to set both ports to switchport mode dynamic desirable (which actually works, but then the ports become trunk ports) How would I do this. I just want to get the 3750 onto Vlan 206, configure an IP address on it, and download firmware.

Thanks for your help,

Gene

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Silver

Re: SPANTREE-7-RECV_1Q_NON_TRUNK

Hello Gene,

remove

switchport voice vlan 207

on both ports this build an implicit two vlans trunk (the mini trunk)

Hope to help

Giuseppe

Re: SPANTREE-7-RECV_1Q_NON_TRUNK

Why not directly connecting your pc to the 3750 switch?

If you just want to allow vlan 206 between the switches and don't want the link to be a trunk:

Following minimal config is required

int fas0/13

switchport access vlan 206

switchport mode access

on 3750

interface FastEthernet1/0/48

switchport access vlan 206

switchport mode access

you don't need these commands for an access port:

switchport trunk encapsulation dot1q

switchport trunk native vlan 206

If you are on the 3750 and wants to access the IOS from another vlan, make sure to have ip default-gateway configured

2 REPLIES
Hall of Fame Super Silver

Re: SPANTREE-7-RECV_1Q_NON_TRUNK

Hello Gene,

remove

switchport voice vlan 207

on both ports this build an implicit two vlans trunk (the mini trunk)

Hope to help

Giuseppe

Re: SPANTREE-7-RECV_1Q_NON_TRUNK

Why not directly connecting your pc to the 3750 switch?

If you just want to allow vlan 206 between the switches and don't want the link to be a trunk:

Following minimal config is required

int fas0/13

switchport access vlan 206

switchport mode access

on 3750

interface FastEthernet1/0/48

switchport access vlan 206

switchport mode access

you don't need these commands for an access port:

switchport trunk encapsulation dot1q

switchport trunk native vlan 206

If you are on the 3750 and wants to access the IOS from another vlan, make sure to have ip default-gateway configured

2755
Views
0
Helpful
2
Replies
CreatePlease to create content