Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

%SPANTREE

Hello I have a issue with spantree. This message appears

Jan 15 13:47:20.640 MEX: %SPANTREE-SP-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk GigabitEthernet1/1 VLAN7.

Jan 15 13:47:20.640 MEX: %SPANTREE-SP-7-BLOCK_PORT_TYPE: Blocking GigabitEthernet1/1 on VLAN0007. Inconsistent port type.

290052: Jan 15 13:47:25.028 MEX: %SYS-5-CONFIG_I: Configured from console by mnet onvty0 (172.18.0.120)

290053: Jan 15 13:48:11.584 MEX: %SYS-5-CONFIG_I: Configured from console by mnet onvty0 (172.18.0.120)

Jan 15 13:48:42.656 MEX: %SPANTREE-SP-2-BLOCK_BPDUGUARD: Received BPDU on port GigabitEthernet1/1 with BPDU Guard enabled. Disabling port.

Jan 15 13:48:42.656 MEX: %PM-SP-4-ERR_DISABLE: bpduguard error detected on Gi1/1, putting Gi1/1 in err-disable state

This occurs when I connect a Cat6500>SwitchAvaya>CatExpress 500.

Here are configured.

Cat6500

interface GigabitEthernet1/1

description "Hacia SW "

switchport

switchport access vlan 7

switchport mode access

no ip address

speed nonegotiate

no cdp enable

Avaya

Plane.

You can see attachment.

I need to knows what do I can configured to this work well?.

Can you help me?.

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: %SPANTREE

If you want to continue using this port as access port, then disable bpduguard on interfce:

int gi1/1

spanning-tree bpduguard disable

Re: %SPANTREE

Spanning tree portfast is not recommended for switch to switch links.

10 REPLIES

Re: %SPANTREE

The errors that you are seeing is because you have an access port connected to a switch that is probably a trunk and sending BPDU's. You should configure Gi1/1 as an 802.1q trunk. Since you have global BPDU guard enabled it puts the port into err-disable.

switchport mode trunk

switchport trunk encapsulation dot1q

Mark

Community Member

Re: %SPANTREE

Thanks for reply but I can not change it already that this access port is neccesary for that this connected to switch X without vlan or vlan1 for default so that catexpress is conneceted to switch.

that is to say.

6500 access port-- switch X(all port Vlan 1)--- CatExpress 500 (all port vlan 1) .

any change I need to do over the switch catalyst express 500. can you tell me how can I to do it?

Re: %SPANTREE

I am not familiar with the CatExpress 500 series switches. You should configure the connected port as an access port on vlan 7 based on your 6500 port.

Re: %SPANTREE

You can also disable the global BPDU guard and enable it on the necessary interfaces.

no spanning-tree portfast bpduguard default

On the interfaces

spanning-tree portfast bpduguard

Community Member

Re: %SPANTREE

In my case I need this command be over interface can I type spanning-tree portfast bpduguard into interface gi 1/1 to do disable the BPDU?

and I have other question can I to use bpdufilter and what is command correct into interface.

Re: %SPANTREE

You will want to disable the global BPDU guard and enable it on the required interfaces.

Re: %SPANTREE

or you can temporarily diable bpduguard and loopguard globally and enable again after you connect your switch. The problem is when you enable bpduguard globally, it is enable on all your access ports when you connect a switch to an access port, bpduguard will error disable that port when any BPDU's is detected on that port.

also remove any bpduguard or loopguard commands from your gig1/1 interface. if you are using access port in a specific vlan, then only that vlan is allowed between your switches unless you enable a trunk.

Re: %SPANTREE

If you want to continue using this port as access port, then disable bpduguard on interfce:

int gi1/1

spanning-tree bpduguard disable

Community Member

Re: %SPANTREE

Thanks for reply. I prefers it but spanning-tree porfast also it should be in int gi 1/1?

Thanks.

Re: %SPANTREE

Spanning tree portfast is not recommended for switch to switch links.

1129
Views
10
Helpful
10
Replies
CreatePlease to create content