Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

speed reduced and drop the packets with QoS

Hi, QoS expert

another QoS thing.

I put a QoS in a  WS-C3560CG-8TC-S  version 12.2(55)EX2.  in our lab

file upload or download speed much reduced and drop the packets with QoS

everyting is fine without QoS

Here is the config

My question is why I speed reduced a lot and packets to be dropped with QoS.

everything is fine WITHOUT QoS.

Let me know and thanks.

*******************

class-map match-any VoIP
  description Voice IP Phone RTP
match access-group 157

class-map match-any WEB
  description Internal Web, SSL Web, DNS query, Pinnacle
match access-group 153

!


policy-map QOSMARK

class VoIP
  set dscp ef

class WEB
  set dscp cs3

class class-default
  set dscp default

access-list 153 remark * WEB class (IP Precedence 2)
access-list 153 remark - HTTP traffic (within local only)
access-list 153 permit tcp any any eq www
access-list 153 permit tcp any eq www any
access-list 153 remark - SSL Web traffic
access-list 153 permit tcp any any eq 443
access-list 153 permit tcp any eq 443 any

access-list 157 remark * VoIP class (IP Precedence 5)
access-list 157 remark - voice RTP packets
access-list 157 permit udp any any range 16384 32767
access-list 157 permit udp any range 16384 32767 any

interface GigabitEthernet0/8

switchport access vlan 874

switchport mode access

service-policy input QOSMARK

4 REPLIES
Cisco Employee

speed reduced and drop the packets with QoS

Hello,

So now you are marking packets with DSCP on incoming interface. Without QoS those not marked - so outgoing interfaces treat all traffic equally (if not marked before or if you don't trust old markings).

Now this traffic is sent out of some outgoing port/ports. Those can do QoS as well - without marking treating all equally - and assigining full interface bandwidth to all traffic going out. With marking set - outgoing interfaces now started to queue before sending out. If the queue size for particular DSCP is quite small - it will definitely start dropping.

What is your goal which you are trying to achieve applying marking? What are the outgoing interfaces for this marked traffic. Please send the config from outgoing interfaces plus hese commands:

show queueing int gix/y

Nik

Super Bronze

speed reduced and drop the packets with QoS

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

One common issue with the 3650/3750, when QoS is enabled, buffer resources that were available for a single queue are now divided to support 4 egress queues.  As Nik also notes, depending on packet marking, some packets might now have insufficient buffer resources and are prematurely dropped.

New Member

speed reduced and drop the packets with QoS

Thanks first.

Is that any CLI can increase the buffer?

My goal is bulk triffic should has the  same speed as without QoS if no high priority traffic.

Switch#show queueing interface g0/4

Interface GigabitEthernet0/4 queueing strategy: none

GigabitEthernet0/4

  Model:                 WS-C3560CG-8TC-S

  Type:                  10/100/1000BaseTX

  Speed:                 10,100,1000,auto

  Duplex:                half,full,auto

  Trunk encap. type:     802.1Q,ISL

  Trunk mode:            on,off,desirable,nonegotiate

  Channel:               yes

  Broadcast suppression: percentage(0-100)

  Flowcontrol:           rx-(off,on,desired),tx-(none)

  Fast Start:            yes

  QoS scheduling:        rx-(not configurable on per port basis),

                         tx-(4q3t) (3t: Two configurable values and one fixed.)

  CoS rewrite:           yes

  ToS rewrite:           yes

  UDLD:                  yes

  Inline power:          no

  SPAN:                  source/destination

  PortSecure:            yes

  Dot1x:                 yes

Super Bronze

speed reduced and drop the packets with QoS

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting

There's CLI commands to "rearrange" buffer resources.

Lots of good information on that in: https://supportforums.cisco.com/docs/DOC-8093

389
Views
0
Helpful
4
Replies
CreatePlease login to create content