Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Split DNS

Hi guys I hope some of you may be able to assist me here.

Probably a simple question?

I have 2 vlans 192.168.1.0 and 10.0.2.0. The 10.0.2.0 vlan is the DMZ with a web server hostting for a few freinds. Everything works just fine the server hosts multiple sites and they resolve from external DNS by host name. The client is not running their own DNS server just a setup for web hosting. However I cannot get it to resolve urls hosted on the webserver from the 192 vlan? I know its a DNS issue, or at least I am pretty sure but am I better setting up DNS on one of the web servers or can I use split DNS?

I tried setting up split dns but found little documentation.

Help appreciated config below.

Current configuration : 4099 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

enable password 7 ccccccccccccccccccc

!

no aaa new-model

!

!

!

!

!

dot11 ssid HOME

authentication open

authentication key-management ffgg

guest-mode

wpa-psk ascii 7 fffffffffffffffffff

!

!

!

no ip dhcp use vrf connected

no ip dhcp conflict logging

ip dhcp excluded-address 192.168.1.254

ip dhcp excluded-address 10.0.2.254

!

ip dhcp pool DHCP_POOL_1

network 192.168.1.0 255.255.255.0

default-router 192.168.1.254

dns-server 94.192.119.254

!

ip dhcp pool VLAN_2

network 10.0.2.0 255.255.255.0

default-router 10.0.2.254

dns-server 208.67.222.222 208.67.220.220

!

!

ip cef

!

no ipv6 cef

multilink bundle-name authenticated

!

!

archive

log config

hidekeys

!

!

!

bridge irb

!

!

interface ATM0

mac-address xxxx.xxxx.xxxx

no ip address

ip virtual-reassembly

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

description **** OUTSIDE ****

ip address 11x.22x.33x.44x 255.255.252.0

ip nat outside

ip virtual-reassembly

atm route-bridged ip

pvc 0/101

no oam-pvc manage

encapsulation aal5snap

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

switchport access vlan 2

!

interface FastEthernet3

!

interface Dot11Radio0

no ip address

!

encryption mode ciphers tkip

!

ssid HOME

!

speed basic-12.0 18.0 24.0 36.0 48.0 54.0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

no ip address

ip virtual-reassembly

bridge-group 1

!

interface Vlan2

ip address 10.0.2.254 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface BVI1

ip address 192.168.1.254 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 123.123.123.1

!

!

ip http server

no ip http secure-server

ip nat inside source list 102 interface ATM0.1 overload

ip nat inside source list 103 interface ATM0.1 overload

ip nat inside source static tcp 10.0.2.1 11x.22x.33x.44x 80 extendable

!

access-list 102 permit ip 192.168.1.0 0.0.0.255 any

access-list 102 permit ip 10.0.2.0 0.0.0.255 any

dialer-list 1 protocol ip permit

!

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

4 REPLIES
Community Member

Re: Split DNS

One question is the web server ip address 10.0.2.1 ? Thanks

Community Member

Re: Split DNS

..

Community Member

Re: Split DNS

yes sorry web server is 10.0.2.1

Community Member

Re: Split DNS

Sorry man I am stuck on this one too, and I am curious as to see what the solution is. Thanks

314
Views
0
Helpful
4
Replies
CreatePlease to create content