Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Split two subnets on one vlan to two vlans?

Time to ask the gang at the Cisco braintrust!  

I have two subnets configured on one VLAN.  I would like to have a router (not a switch) re-map the subnets to an individaul vlan.

Example:

192.168.0.1/24 - VLAN 10        f0/0.10                            f0/1.10         192.168.0.1/24  - VLAN 10

                                     ------------------------Router-------------------------------

10.0.0.1/24       - VLAN 10        f0/0.10                            f0/1.20         10.0.0.1/24        - VLAN 20

The router is addressed as x.x.x.254 on both subnets.

I've fired up my copy of GNS3, and I've tried vlan-bridging, ieee bridging, and BVI's, but I'm just not grasping it correctly.

Most of the information I Google for talks about vlan bridging on switches.  I DO NOT have a switch.  I would like to do this within the router itself.

Is this scenario possible on a cisco router?

Everyone's tags (3)
7 REPLIES
Silver

Split two subnets on one vlan to two vlans?

If your router supports VLANS. You need the advanced IP services IOS. Otherwise You only get one VLAN

Assuming that you have the right IOS the commands on the router are EXACTLY the same as the switch.

You disable the IP on the ethernet.

Define the vlan interfaces.

use switch-port access vlan N on each ethernet.

show vlan-switch

---

Posted by WebUser Stuart Gall

New Member

Split two subnets on one vlan to two vlans?

Stuart,

I'm using entservicesk9-12.4(13b).  It shows the vlans  on the command 'show vlan-switch,' but It will not allow a Vlan nn  interface.  There is NO ESW module.  The router only has two FE ports.  I thought that you could only define vlan interfaces on systems with a switch module.

Sounds like I may be looking for an update?

Bronze

Split two subnets on one vlan to two vlans?

You don't need to create vlan if you are using physical interfaces. Just give ip address for each interface in respective vlan. If you want to use subinterfaces (router-on-a-stick), then you can assign that subinterface to a vlan and need to have a trunk link between the router and switch. In gns3 you can configure a router with switchports (has a module with 16 ports) to act as a switch, where you configure ports, vlans and assign them to vlans. The switch in gns3 is not configurable, except to add ports to it.

Hope this helps

Eugen

New Member

Re: Split two subnets on one vlan to two vlans?

I wanted to do this WITHOUT a switch module.  After a few hours of tweaking...here is the relavant part of the config:

!
bridge irb
!
!
!
interface FastEthernet0/0
no ip address
no ip route-cache cef
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip unnumbered BVI1
no ip route-cache
bridge-group 1
!
interface FastEthernet0/1
no ip address
no ip route-cache cef
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0/1.10
encapsulation dot1Q 10
ip unnumbered BVI1
no ip route-cache
bridge-group 1
!
interface FastEthernet0/1.20
encapsulation dot1Q 20
ip unnumbered BVI1
no ip route-cache
bridge-group 1
!
interface BVI1
ip address 10.0.0.254 255.255.255.0 secondary
ip address 192.168.0.254 255.255.255.0
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
!

This 'seems' to work, but I'm open to any sugestions to clean it up, and perhaps, add some filtering!  I've read that this will put a processing strain on the router, too. 

It's a real PITA to support legacy networks!

--

Larry

Bronze

Split two subnets on one vlan to two vlans?

If the requirements are to use bridged interfaces than your config should work. Usualy routers provide intervlan routing and since you have only 2 vlans in your network I would configure each interface with ip addresses in each vlan and reduce the strain on the CPU. But that is just an opinion, you should consider other advice as well.

Regards

Eugen

New Member

Split two subnets on one vlan to two vlans?

To followup on a few posed questions...

I need to 'split the subnets' because I must feed the streams into another box that will NOT accept two subnets on the same VLAN.  Each subnet must have a seperate VLAN.  The sad part is that it IS a Cisco box.

Eugen,

The bridged setup is just the first thing that crossed my mind.  I tried placing the IP addresses on the individual sub-interfaces, but I would get IOS errors doing that.   I had to work with the single IP address/subnets, and adding more would just mess up the rest of the network.  All of my searching on the Net for some other solution would turn up information on routing stuff like LAT or IPX. 

On a Cisco, there's always more than one way to do something.  It's just a matter of 'sharing' it with the rest of the community.  This is my quick & dirty solution.  As I learn more, I can refine it!  I hope it helps someone else out.

Silver

Split two subnets on one vlan to two vlans?

show vtp status - tells you amongst other things how many local VLANS are supported 1 and 1002 to 1005 are reserved so 5 vlans means basically none.

---

Posted by WebUser Stuart Gall

1859
Views
0
Helpful
7
Replies
CreatePlease to create content