Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SSH Connection Problems

Could use some help here. I have an older version of Cirrus Config Manager that I used to upload config changes. It logs in to systems using SSH. Occasionally after it logs in though, something happens and I can no longer connect using SSH to that device unless I reboot it (telnet still works). Using putty, I get a message saying that the "Server unexpectedly closed network connection". After a reboot, I can get into the router (this seems like it is only happens on routers, and not switches). I know I have read that this happens if you change the hostname of the device, but the host name hasn't changed when this happens. I have tried to delete and regenerate the RSA key, but still no luck.




Re: SSH Connection Problems

It can also happen if you have to replace the device and or supervisor as the new key will not match the stored key in the device you are ssh'ing from, I have seen this going from a unix device and you have to clear the key for that device and make a new one . Also make sure you have your exec-timeout parameters set on the vty sessions.

CreatePlease login to create content