Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Stacking / Etherchannel Question

I have a network to install that was originally designed to be;

two distribution switchesthat are WS-C2960S-48FPD-L stacked. These are connected via two TEN Gig ports in etherchannel back to a 6513E.

The Access layer was to be 3WS-C2960S-48TS-L switches that were all stand alone, each with two, one gig uplinks one back to each of the distribution switches in an etherchannel. Now they would like the three access layer switches to be stacked. This access layer stack would have two, one gig uplinks in an etherchannel. One port of the etherchannel would land on switch 1 port 48 and the other port in the etherchannel would land on switch 3 port 48.

So I guess I really have three questions.

One can I hang a 2960 stack of three switches that are (access) off of a 2960 stack of two switches that is the (distribution)

Two Can I ethercahnnel between the two different stacks.  

Third question is really configuration help.

The Etherchannel that I have between the Core 6513 E and the distribution WS-C2960S-48FPD-L is configured as follows:

On the 6513E

interface Port-channel6

description PS-*******-STK-0

switchport

switchport mode trunk

shutdown

platform qos trust cos

interface TenGigabitEthernet9/11

description UPLINK:PS-*******-STK-0-A

switchport

switchport mode trunk

shutdown

platform qos trust cos

udld port aggressive

channel-group 6 mode active

!

interface TenGigabitEthernet9/12

description UPLINK:PS-*******-STK-0-B

switchport

switchport mode trunk

shutdown

platform qos trust cos

udld port aggressive

channel-group 6 mode active

On the distribution switches WS-C2960S-48FPD-L

interface Port-channel6

description UPLINK<>CS-*******-0

switchport mode trunk

ip dhcp snooping trust

interface TenGigabitEthernet1/0/2

description UpLink<> CS-*******-0

switchport mode trunk

shutdown

udld port aggressive

channel-group 6 mode active

ip dhcp snooping trust

interface TenGigabitEthernet2/0/2

description UpLink<> CS-*********-0

switchport mode trunk

shutdown

udld port aggressive

channel-group 6 mode active

ip dhcp snooping trust

Does this above config look alright?

And would the following config work?

DistributionWS-C2960S-48FPD-L

interface Port-channel1

description DNLINK<>SS-*********-STK-0

switchport mode trunk

ip dhcp snooping trust

interface GigabitEthernet1/0/48

description DNLink<>SS-********-STK-0

switchport mode trunk

shutdown

udld port

channel-group 1 mode active

ip dhcp snooping trust

interface GigabitEthernet2/0/48

description DNLink<>SS-*********-STK-0

switchport mode trunk

shutdown

udld port

channel-group 1 mode active

ip dhcp snooping trust

Access Layer WS-C2960S-48TS-L (stack of 3 WS-C2960S-48TS-L)

interface GigabitEthernet1/0/48

description DNLink<>SS-*********-STK-0

switchport mode trunk

shutdown

udld port

channel-group 1 mode active

ip dhcp snooping trust

interface GigabitEthernet3/0/48

description DNLink<>SS-*********-STK-0

switchport mode trunk

shutdown

udld port

channel-group 1 mode active

ip dhcp snooping trust

7 REPLIES
Hall of Fame Super Gold

Re: Stacking / Etherchannel Question

Two Can I ethercahnnel between the two different stacks

No.

Brain not working correctly this morning, folks. 

New Member

Stacking / Etherchannel Question

Leo

Could you elaborate? From a design perspective would it be better to leave the three access layer switches as stand alone and then etherchannel between each of these and the 2960 distribution stack?

Hall of Fame Super Gold

Re: Stacking / Etherchannel Question

You can't have a server (with dual NICs) and go to two different switches in an etherchannel.

The two switches must form a single logical etherchannel and this will work.

It sure is a lousy time to quit caffine. 

Hall of Fame Super Gold

Re: Stacking / Etherchannel Question

Two Can I ethercahnnel between the two different stacks

Mike,

Take two:  You have two switch stacks and you want to link them together with etherchannel?  Sure.  Why not?

New Member

Stacking / Etherchannel Question

Leo

So I will create etherchannels between my two stacks They will l be configured as stated above. Is it a good design to have the etherchannels terminate on the access switches switch 1 and switch 3 ?

Quiting caffeine is a tough one. I have done it twice..and have gone back to caffeine after some time. I just cant hardly do a morning without at least one cup of coffee.

Hall of Fame Super Gold

Re: Stacking / Etherchannel Question

No problem with what you are doing, Mike.

Some of my 2960S have etherchannel back to the distro switch.

Sent from Cisco Technical Support Nintendo App

Hall of Fame Super Blue

Stacking / Etherchannel Question

Leo

I would be interested in the answer as well.  I think, if i understand correctly, Mike doesn't mean the same end of the etherchannel, he means can you etherchannel from one stack to another stack. I thought this could be done but you know this stuff a lot better than me.

Is it a restriction on the switches ie. with VSS i believe you can run a MEC from one VSS pair to another which is effectively the same thing.

Jon

114
Views
0
Helpful
7
Replies