Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

%STANDBY-3-DUPADDR: Duplicate address Error message

I am getting this error message on my core 6509 and am trying to track down the root cause. What are some tips that you can provide?

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: %STANDBY-3-DUPADDR: Duplicate address Error message

Hi Paul,

These error messages can appear:

Oct 12 13:15:41: %STANDBY-3-DUPADDR: Duplicate address 10.25.0.1

on Vlan25, sourced by 0000.0c07.ac19

Oct 13 16:25:41: %STANDBY-3-DUPADDR: Duplicate address 10.25.0.1

on Vlan25, sourced by 0000.0c07.ac19

Oct 15 22:31:02: %STANDBY-3-DUPADDR: Duplicate address 10.25.0.1

on Vlan25, sourced by 0000.0c07.ac19

Oct 15 22:41:01: %STANDBY-3-DUPADDR: Duplicate address 10.25.0.1

on Vlan25, sourced by 0000.0c07.ac19 These error messages do not necessarily indicate an HSRP problem. Rather, the error messages indicate a possible Spanning Tree Protocol (STP) loop or router/switch configuration issue. The error messages are just symptoms of another problem.

In addition, these error messages do not prevent the proper operation of HSRP. The duplicate HSRP packet is ignored. These error messages are throttled at 30-second intervals. But, slow network performance and packet loss can result from the network instability that causes the STANDBY-3-DUPADDR error messages of the HSRP address.

These error messages can appear:

Oct 15 22:41:01: %STANDBY-3-DUPADDR: Duplicate address 10.25.0.1

on Vlan25, sourced by 0000.0c07.ac19 These messages specifically indicate that the router received a data packet that was sourced from the HSRP IP address on VLAN 25 with the MAC addresses 0000.0c07.ac19. Since the HSRP MAC address is 0000.0c07.ac19, either the router in question received its own packet back or both routers in the HSRP group went into the active state. Because the router received its own packet, the problem most likely is with the network rather than the router. A variety of problems can cause this behavior. Among the possible network problems that cause the error messages are:

Momentary STP loops

EtherChannel configuration issues

Duplicated frames

When you troubleshoot these error messages, see the troubleshooting steps in the HSRP Troubleshooting Modules for CatOS Switches section of this document. All the troubleshooting modules are applicable to this section, which includes modules on configuration. In addition, note any errors in the switch log and reference additional case studies as necessary.

You can use an access list in order to prevent the active router from receiving its own multicast hello packet. But, this is only a workaround for the error messages and actually hides the symptom of the problem. The workaround is to apply an extended inbound access list to the HSRP interfaces. The access list blocks all traffic that is sourced from the physical IP address and that is destined to all routers multicast address 224.0.0.2.

access-list 101 deny ip host 172.16.12.3 host 224.0.0.2

access-list 101 permit ip any any

interface ethernet 0

ip address 172.16.12.3 255.255.255.0

standby 1 ip 172.16.12.1

ip access-group 101 in

You can refer this URL for Troubleshooting also:

http://www.cisco.com/en/US/tech/tk648/tk362/technologies_tech_note09186a0080094afd.shtml#t12

Rgeards,

Dharmesh Purohit

3 REPLIES
Silver

Re: %STANDBY-3-DUPADDR: Duplicate address Error message

Hi Paul,

These error messages can appear:

Oct 12 13:15:41: %STANDBY-3-DUPADDR: Duplicate address 10.25.0.1

on Vlan25, sourced by 0000.0c07.ac19

Oct 13 16:25:41: %STANDBY-3-DUPADDR: Duplicate address 10.25.0.1

on Vlan25, sourced by 0000.0c07.ac19

Oct 15 22:31:02: %STANDBY-3-DUPADDR: Duplicate address 10.25.0.1

on Vlan25, sourced by 0000.0c07.ac19

Oct 15 22:41:01: %STANDBY-3-DUPADDR: Duplicate address 10.25.0.1

on Vlan25, sourced by 0000.0c07.ac19 These error messages do not necessarily indicate an HSRP problem. Rather, the error messages indicate a possible Spanning Tree Protocol (STP) loop or router/switch configuration issue. The error messages are just symptoms of another problem.

In addition, these error messages do not prevent the proper operation of HSRP. The duplicate HSRP packet is ignored. These error messages are throttled at 30-second intervals. But, slow network performance and packet loss can result from the network instability that causes the STANDBY-3-DUPADDR error messages of the HSRP address.

These error messages can appear:

Oct 15 22:41:01: %STANDBY-3-DUPADDR: Duplicate address 10.25.0.1

on Vlan25, sourced by 0000.0c07.ac19 These messages specifically indicate that the router received a data packet that was sourced from the HSRP IP address on VLAN 25 with the MAC addresses 0000.0c07.ac19. Since the HSRP MAC address is 0000.0c07.ac19, either the router in question received its own packet back or both routers in the HSRP group went into the active state. Because the router received its own packet, the problem most likely is with the network rather than the router. A variety of problems can cause this behavior. Among the possible network problems that cause the error messages are:

Momentary STP loops

EtherChannel configuration issues

Duplicated frames

When you troubleshoot these error messages, see the troubleshooting steps in the HSRP Troubleshooting Modules for CatOS Switches section of this document. All the troubleshooting modules are applicable to this section, which includes modules on configuration. In addition, note any errors in the switch log and reference additional case studies as necessary.

You can use an access list in order to prevent the active router from receiving its own multicast hello packet. But, this is only a workaround for the error messages and actually hides the symptom of the problem. The workaround is to apply an extended inbound access list to the HSRP interfaces. The access list blocks all traffic that is sourced from the physical IP address and that is destined to all routers multicast address 224.0.0.2.

access-list 101 deny ip host 172.16.12.3 host 224.0.0.2

access-list 101 permit ip any any

interface ethernet 0

ip address 172.16.12.3 255.255.255.0

standby 1 ip 172.16.12.1

ip access-group 101 in

You can refer this URL for Troubleshooting also:

http://www.cisco.com/en/US/tech/tk648/tk362/technologies_tech_note09186a0080094afd.shtml#t12

Rgeards,

Dharmesh Purohit

Silver

Re: %STANDBY-3-DUPADDR: Duplicate address Error message

Thanks, You got it useful.

Regards,

Dharmesh

Re: %STANDBY-3-DUPADDR: Duplicate address Error message

Paul,

It seems that you have a layer-2 loop in the network. You need to eliminate all possible

loops created by trunks & verify that stp is running properly.

In these switches all the ports have stp enabled by defualt. If you have port-fast enabled in one of them it will set the port immediately into forwarding state. If such port is connected to a switching device stp can be overriden and a loop can't be detected nor contained. Make sure this is not the case.

Port-fast is used only when you are absolutely sure that the device connected to the port

is an end-user device like a PC or a printer.

Regards,

~JG

1072
Views
0
Helpful
3
Replies
CreatePlease to create content