Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Static ARP on an LD?

Does anyone know how to apply a static ARP to a 430 local director rnuning 3.3.4.

I have used the command :

arp x.x.x.x aaaa.bbbb.cccc 2

and this seems to have only made a 'normal' dynamic entry that ages after a time.

Any help would be much appreciated.

Thanks

Dan

8 REPLIES
Bronze

Re: Static ARP on an LD?

Hi Dan,

Use the word

alias to make your arp static

Use this command:

arp x.x.x.x aaaa.bbbb.cccc 2 alias

Syntax: arp ip mac_address interface_number [alias]

(Optional) Alias entries do not time out and are stored in the configuration with the write command. Alias entries stay in the ARP table after LocalDirector reboot if they are saved in the configuration.

Hope this helps

Thanks,

Raj

New Member

Re: Static ARP on an LD?

Hi Raj,

Thanks for the info. (have rated it)

Dan

New Member

Re: Static ARP on an LD?

I've put in the statics. When I do a 'show arp' straight afterwards then the entry has 'alias' written next to it. After a minute or two, the alias disappears and it looks like any other ARP entry. This is odd. There seems to be no way of knowing that it is a static as it doesn't appear in the config either. (I did the statement arp x.x.x.x dddd.eeee.ffff 2 alias in conf t mode and saved the config)

The weird thing is that the standby LD has them as alias entries and they are in the config.

Can anyone explain this ?

TIA

Dan

New Member

Re: Static ARP on an LD?

Just to clarify : By ' the alias disappears' I mean it doesn't show next to the entry when doing a 'show arp'.

rgds

Dan

Bronze

Re: Static ARP on an LD?

Hi Dan,

alias is optional command and the only way to identify this static arp statements by checking your config. Thats why u need to write to memory.

HTH

Thanks for rating

Raj

New Member

Re: Static ARP on an LD?

Performing a wr mem a while after implementing the static ARPs seems toclear them out. They dont seem to be that static after all.

I had two statics in the config and checked that they were there before adding another two. I added another two, did a wri mem, and checked the config and the original two had disappeared.

This seems to mean that you would have to configure the statics everytime you make a change to these devices.

Can anyone comment on this? Is it normal or am I missing something?

TIA

Dan

Bronze

Re: Static ARP on an LD?

Hi Dan,

Check this link for more information about the alias command and static arp .

http://www.cisco.com/en/US/products/hw/contnetw/ps1894/products_configuration_guide_chapter09186a008007f4c2.html#1015619

Hope this helps you,

Thanks,

Raj

New Member

Re: Static ARP on an LD?

Thanks for your help Raj. We have now had to find another workaround.

I had seen the document you linked to above and I confirm that we have seen different results and that the ARPs do seem to be wiped out the config with subsequent 'write mem's.

I would investigate further and log a tac case but I have more pressing things to do at present.

Thanks for all your help anyway.

rgds

Dan

392
Views
5
Helpful
8
Replies
CreatePlease to create content