Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Static NAT entries - adding static routes by default

Hi, Hi,

I have a 2600 running

flash:c2600-i-mz.122-8.T5.bin

Some static nat entries are configured, and I am seeing static routing entries being entered into the routing table without any configuration to do so. I don't see anything in the config that would account for this, and this isn't standard IOS behavior...

Am I missing something, or does this look like an IOS rev issue?

There's no interface on the router that is in either address space, so there should be no weird issues like that...

FastEthernet0/0 is administratively down, line protocol is down

Serial0/0 is up, line protocol is up

Internet address is 192.168.235.82/30

Serial0/1 is up, line protocol is up

Internet address is 10.122.124.2/30

Loopback0 is up, line protocol is up

Internet address is 1.1.1.1/32

Loopback2 is up, line protocol is up

I don't want these static routes in my table as they are altering some dynamic routing.

Thanks!

Lisa G

snippets of the config:

ip nat outside source static 144.226.228.143 192.168.232.60

snippet from the routing table:

S 192.168.232.60/32 [1/0] via 144.226.228.143

2 REPLIES
Hall of Fame Super Blue

Re: Static NAT entries - adding static routes by default

Lisa

There is an option with the "ip nat outside .." command called "add-route". If you add this at the end of the line it will add a static route into the routing table for the NAT translation as is happening with you.

Obviously you haven't got this in your config but i wonder if it is adding it anyway by default. Perhaps an IOS issue as you say.

I have tested on a 2600 and don't get this problem but i haven't tried with your IOS. If i get a chance i'll try it out.

Jon

New Member

Re: Static NAT entries - adding static routes by default

Thanks Jon for that info. i didn't know that there was an add on to the nat outisde command for adding static routes. I think this is obviously a bug so I will check out bug toolkit or open a case to get the fixed rev.

Thanks for your help!

Lisa G

121
Views
5
Helpful
2
Replies
CreatePlease to create content