Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Static NAT from Internal Interface to Internal Interface

I have a  1711 running 12.4 and already have NAT running in overload from all inside interfaces to the outside. This works fine without issue.

In order for traffic to be routed through the 3rd party CRM gateway, the traffic needs to have a 161 address. I would like to configure the router to NAT all traffic coming in on VLAN 160 to have an address on the 161 VLAN.

remoteVPN.jpg

Below are the relevant lines in the existing configuration:

interface FastEthernet0

description FastEthernet0: Outside

ip address 4.xx.xx.154 255.255.255.252

ip access-group 109 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip flow egress

ip nat outside

ip inspect holiday out

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

no cdp enable

!

....

interface FastEthernet3

switchport access vlan 160

!

....

interface Vlan160

ip address 10.28.160.253 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

!

interface Vlan161

ip address 10.28.161.253 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip flow egress

ip nat inside

ip virtual-reassembly

!

....

!

ip nat pool ovrld 4.xx.xx.154 4.xx.xx.154 netmask 255.255.255.252

ip nat inside source list 7 pool ovrld overload

....

access-list 7 permit 10.28.161.0 0.0.0.255

I'm thinking that I need to use a Route-Map to identify the correct interface but I'm not certain that you can mix access list NAT with route map NAT and how you would go about implementing it.

I appreciate any help you may offer.

Everyone's tags (3)
332
Views
0
Helpful
0
Replies
CreatePlease to create content