Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

static nat route-map with dynamic translation

There were problems with the configuration of static nat with the route-map and dynamic translation.

There is such a configuration:

ip nat inside source static 172.21.34.118 10.205.6.12 route-map net10

ip nat inside source static 172.21.34.118 172.24.172.6 route-map net172

ip nat inside source static 172.21.34.117 10.205.6.11 route-map net10

ip nat inside source static 172.21.34.117 172.24.172.5 route-map net172

access-list 101 permit ip 172.21.34.0 0.0.0.255 172.24.172.0 0.0.0.255

access-list 102 permit ip 172.21.34.0 0.0.0.255 10.200.4.0 0.0.0.255

route-map net172 permit 10

match ip address 101

!

route-map net10 permit 10

match ip address 102

!

works as I need.

Now there was a need addresses from the network to broadcast 172.21.34.0/24 dynamically to the interface.

ip access-list extended ACL_NAT_TEC

permit ip 172.21.34.0 0.0.0.255 172.24.172.208 0.0.0.7

ip nat inside source list ACL_NAT_TEC interface Serial1 / 1:0 overload

Ceases to operate static translation, addresses 172.21.34.117 and 172.21.34.118 translate to the interface address. What could be a problem. I want to work together and static and dynamic nat.

Thanks in advance.

1 REPLY

Re: static nat route-map with dynamic translation

Try to modify your ACL_NAT_TEC so that it excludes the static entries.

regards,

Leo

112
Views
0
Helpful
1
Replies
CreatePlease to create content