Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

static route fails

Hi all,

Im new here and want do practise the dealing with cisco switches.

I have a test switch here with this config:

The port 1 is connected with a firewall. Between firewall and switch i have a transfernetwork.

Switchport1: 192.168.0.1 and Firewallport 192.168.0.2

And we have a defaultroute

ip default-gateway 192.168.0.2

ip route 0.0.0.0 0.0.0.0. 192.168.0.2

So all clients take the defaultroute.

Now i have a second firewall connected with Port 2

I have created a VLAN 10 and add the ip 10.10.20.254 to the VLAN 10

Applied VLAN 10 to the port 2

The second firewall which is connected with Port 2 is configured with the ip: 10.10.20.1

So i have a transfernetwork between Port2 and the second firewall

after that i done this:

enable

conf t

ip route 15.240.60.238 255.255.255.255 10.10.20.1

exit

Now if i run traceroute to 15.240.60.38 the first hop should be the 10.10.20.1

But it is still 192.168.0.2

Hmmm

any idea what im doing wrong?

if i run show ip route

the new rout is not listed

if i run show running-conf

i see this:

ip route 15.240.60.238 255.255.255.255 10.10.20.1

hope you can help me

Thanks all

3 REPLIES
Purple

static route fails

Hi,

Can you post sh ip int br output as well as sh int status output

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

static route fails

Hi:

   you set

   ip route 15.240.60.238 255.255.255.255 10.10.20.1.the mask is /32 .

   but you try traceroute to 15.240.60.38,so it still use your default route.

   so the new route list is not be used.

   if you ip address is 15.240.60.38 255.255.255.0,you can ip route 15.240.60.0 255.255.255.0 10.10.20.1

Thanks

Cena

New Member

static route fails

Hello,

What is the model of your switch?

Because maybe you try to do routing on a L2 switch?

163
Views
0
Helpful
3
Replies
CreatePlease to create content