Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Static route for the global routing table using as a next hop it´s own interface that is part of a vrf

Thanks in advance for your inputs.

This is the scenario

Customer

Network       ---------PE1-------MPLS cloud--------PE2----172.16.4.0/24

172.16.10.0/24

- PE1 and PE2 have a BGP vnpnv4 session between them

A router in the MPLS cloud needs to reach the 172.16.10.0/24 network via PE2 so we configured a static route pointing to PE2, then on PE2 there is a global static route like this:

ip route 172.16.10.0 255.255.255.255 vlan400 172.16.4.1

!

interface vlan400

ip vrf forwarding ABC

ip address 172.16.4.1 255.255.255.252

So this is the deal, I need the global routing table to know about the customer´s network going through an interface that is part of a vrf but I don´t have another router to point it as a next-hop of the static route, instead I had to put 172.16.4.1 (it´s own interface) on PE2 as the next-hop but of course this isn´t working. How can I communicate with 172.16.10.0/24 from the service provider network itself?

Thanks, Jorge

4 REPLIES
VIP Super Bronze

Re: Static route for the global routing table using as a next ho

Jorge,

172.16.10.0/24 is in VRF ABC or global?

Your mask is 255.255.255.255, Are you trying to reach a host in 172.16.10.0/24 network?

One thing you could do is to create a loopback address and make a part of VRF ABC and global and point to it as your next hop,as long as it is reachable from 172.16.10.0/24 subnet.

HTH

Reza

Community Member

Re: Static route for the global routing table using as a next ho

Thanks,

172.16.10.0/24 is behind VRF ABC of PE1.

Sorry, in the router itself the mask is correct, it is 255.255.255.0

What do you mean with: create a loopback address and make a part of VRF ABC "and" global.

I can add it to VRF ABC but what do you mean with "and"

- Jorge

VIP Super Bronze

Re: Static route for the global routing table using as a next ho

Like this:

interface Loopback0
ip vrf receive ABC
ip address 130.130.0.1 255.255.255.255
ip policy route-map fake

route-map fake permit 10
set vrf ABC

With this config 130.130.0.1 is reachable via global and vrf ABC

HTH

Reza

Community Member

Re: Static route for the global routing table using as a next ho

Reza,

It´s giving me a problem

interface Loopback11
ip vrf receive ABC
ip address 130.130.0.1 255.255.255.255
ip policy route-map fake
!

PE2(config)#ip route 172.16.10.0 255.255.255.0 vlan 400 130.130.0.1
%Invalid next hop address (it's this router)

Thanks for your help

730
Views
0
Helpful
4
Replies
CreatePlease to create content