Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

static route not being added to routing table

I have an 1841 with a WIC-1ADSL-DG and am using Port Address Translation and I recently added a HWIC-4ESW etherswitch card. I have a class C address assigned to the default vlan and a different class C address assigned to f0/0. The problem is that when I went to add two static routes so that computers attached to the etherswitch card will be able to access the lan on f0/0 and the internet, the static route to the vlan did not show up in the routing table.

The following are the three routes that I have in my config file:

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route x.x.x.0 255.255.255.0 f0/0

ip route x.x.x.0 255.255.255.0 vlan1

the last route is the one that would not show up in my routing table. As result any computer attached to the etherswitch card (vlan1) can ping any computer attached to f0/0, but will not go out on the internet.

12 REPLIES

Re: static route not being added to routing table

first why u need to creat static route for vlan1 and fa0/0?

do u have any other router connected to those interfaces?

if not i mean only hosts connected to those ports u dont need the static route

because

once u creat the vlan interface

it show show u as a directly connected interface

and a bout fa0/0

u can also creat another vlan interface and make fa0/0

part of it

the following link will guid u step by step to configure ur etherswitch

http://www.cisco.com/en/US/products/hw/modules/ps2797/products_configuration_example09186a00808066b8.shtml

good luck

please,, if helpful Rate

New Member

Re: static route not being added to routing table

Whenever I try to assign vlan1 an IP address that is on the same class C as fa0/0, it gives me the following error:

"% x.x.x.0 overlaps with FastEthernet0/0"

It will only accept an IP address that is on a completely separate class C, there for I need to add some static routes if I want the vlan to be able to access the fa0/0 lan and the internet.

Re: static route not being added to routing table

ofcourse u cant

u cant have two routed interface with the same subnet range IPs

lets say the following example

interface vlan 1

ip address 192.168.1.1 255.255.255.0

interface fa0/0

ip address 192.168.1.50 255.255.255.0

in the above example u will get anerror same to what u are getting now

so to solve it

do

interface fa0/0

ip address 192.168.2.50 255.255.255.0

now u have put interface fa0/0 in deffrent subnet and will work normaly

good luck

if u need any more details just post here :)

please, if helpful rate

New Member

Re: static route not being added to routing table

No it won't. That is what I'm doing now and the problem is that then vlan1 won't have access to fa0/0 or the internet without adding some routes to the routing table. If you read my original post you will see the problem that I'm having in adding those routes to the routing table.

Blue

Re: static route not being added to routing table

Please post the entire config and, if possible, do not "X" out the addresses. If they are private addresses, you dont have to X them out.

Thanks

Hall of Fame Super Silver

Re: static route not being added to routing table

Victor is correct that it will be easier to resolve this if we have the complete config to look at. It would also be helpful to have the output of show ip route.

When a subnet (or network) is assigned to the VLAN interface it should show up in the routing table as a connected route. And a static route for the same prefix should not show up in the routing table. I suspect that this may be why the static route for VLAN 1 does not show up. I am quite curious about the static route for F0/0. The original post seems to imply that this static route does show up. I wonder if that is really the case.

HTH

Rick

Hall of Fame Super Silver

Re: static route not being added to routing table

Hello Rafe,

you had your router configured and working and then you added an etherswitch.

If you want to provide internet access to the etherswitch's ports users in vlan 1 what you need is :

a change on your NAT rules so that also source addresses of VLan1, that cannot be the same as int f0/0 as noted in previuos posts, can be translated when going to the internet

you don't need static routes on a single router to route traffic between connected interfaces

Hope to help

Giuseppe

New Member

Re: static route not being added to routing table

Thanks, but I acutally got it working last yesterday. As it turns out, it was a problem with NAT. Althought the class C that I have on the vlan interface still isn't showing up in the routing table for some stange reason. But, I don't care anymore because like I said, I got it working. :)

New Member

Re: static route not being added to routing table

Wouldn't it be better to take the IP address off of the physical port and put the F0/0 interface into VLAN1? That way you won't need to route, you just assign the IP address of (say)192.168.2.254 255.255.255.0 to VLAN1 and make F0/0 in VLAN1.

Is this a bit simplistic? Have I missed the point?

Tim

Hall of Fame Super Silver

Re: static route not being added to routing table

Hello Tim,

this can be done or not depending on router platform.

int fas0/0 is a router port and expects to have an ip address.

I can put int fas0/0 and vlan 1 in the same bridge-group and then I can assign the ip address and the ip nat inside to the BVI interface (the L3 interface of bridge-group using integrated routing and bridging).

I'm not sure that is possible on a router.

In other words I suppose that:

int fas0/0

(1)switchport

(1)switchport mode access

(1) switchport access vlan 1

can be rejected by the CLI

I would suggest

bridge 1 route ip

bridge 1 protocol ieee

int fas0/0

no ip address

bridge-group 1

int vlan1

no ip address

(2) bridge-group 1

int bv1

ip address x.x.x.x 255.255.255.0

ip nat inside

but I'm afraid that (2) could be not accepted.

Solution 1) that you have suggested could work on a C870, but here is using a C2600 or more, because it has inserted an etherswitch module.

In this kind of platform I think switchport commands are accepted on etherswitch's ports only, but I may be wrong.

On the other side I used inter-vlan bridging on a C3550 and I don't know if here it is allowed (command (2) above).

So the answer is that your solution can work but it should be tested.

In theory is a good solution. In my previous post I wanted to move focus on NAT because it is that feature that allows to go to the internet.

The router routes between connected L3 interfaces without any need of static routes

Only the default route out dialer1 is needed here.

Hope to help

Giuseppe

New Member

Re: static route not being added to routing table

I've had others give that exact same suggestion, but I just can't stand wasting a port on the etherswitch by doing that, but it really dosn't matter any more because I got it working the way I wanted yesterday. :)

Hall of Fame Super Silver

Re: static route not being added to routing table

Hello Rafe,

nice to hear you solved your issue

May I ask you what you have done to have it working ?

Best Regards

Giuseppe

1028
Views
0
Helpful
12
Replies
CreatePlease to create content