Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Static vs LACP

Hi,

We have a setup where we connect a stack cisco 3750 to a Procurve HP4204vl switch using port channel and Trunks to team up 4 gigabit ports for 4 gigs throughput. Just want to know the real difference and benefits etc of static and using LACP protocol. Did notice that traffic will just use a particular interface of the 4 interface bundled and not across the bundled ports. And if I have to change the protocols on each switch will it make any differenece and will it have an effect on my the portchannel/trunk uplink i.e shut it down ? Here is the summary of what is configured on both switches

Cisco

Ports:  Gi1/0/23, Gi1/0/24, Gi2/0/23, Gi2/0/24

configuration

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

interface configuration of all 4 ports

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

channel-group 1 mode on

HP

Ports: A17,A18,A19,A20

configuration

trunk A17-A20 Trk2 Trunk

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Static vs LACP

If you plan on converting from ON to LACP mode, you can expect some downtime. Even if you were to configure both ends of the port-channel at the EXACT same time, they will still have to perform negotiation to bring up the port-channel using the LACP protocol. I would expect to see a loss of 2-3 seconds if performed properly. Just make sure you configure the downstream switch first ! As soon as you make the configuration on the upstream switch, you will lose connectivity to the downstream (assuming there is no additional redundancy) and will not be able to perform the configuration to convert the port-channel to LACP.

4 REPLIES
Cisco Employee

Static vs LACP

Hello,

The LACP is a control protocol, or a signalling protocol, that negotiates the creation of an EtherChannel ('Trunk' in HP parlance) between two devices. Its primary purpose is to decide if the ports can be bundled at all and what ports should be bundled. The criteria encompass ports being configured identically, connected to the same opposite device, grouped into the same bundle, the other device willing to bundle its ports as well, etc. LACP is not concerned with frame distribution among different ports in a bundle, nor is it concerned in any way with their format.

The use of LACP is strongly recommended. Using the "on" mode is dangerous as in certain scenarios when one device is already configured and the other is not, switching loops and/or MAC address flapping can occur. I have seen similar scenarios during my SWITCH course trainings far too often.

My recommendation - avoid using the "on" mode at all costs. Use it only if one of the devices does not support LACP. There is nothing to lose with LACP; there is much to lose with "on".

Best regards,

Peter

New Member

Static vs LACP

Thanks Peter for the informative information. Just a quick question. If I change my configs to use LACP on my live environment, will it affect my uplinks ? As at moment I have much to lose with the "on" mode with both my Cisco and HP supporting LACP

Let me know

Bronze

Static vs LACP

If you plan on converting from ON to LACP mode, you can expect some downtime. Even if you were to configure both ends of the port-channel at the EXACT same time, they will still have to perform negotiation to bring up the port-channel using the LACP protocol. I would expect to see a loss of 2-3 seconds if performed properly. Just make sure you configure the downstream switch first ! As soon as you make the configuration on the upstream switch, you will lose connectivity to the downstream (assuming there is no additional redundancy) and will not be able to perform the configuration to convert the port-channel to LACP.

New Member

Static vs LACP

Thank you very much all for your helpful posts

11504
Views
0
Helpful
4
Replies
CreatePlease to create content