Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Storm Control issue

Hi

I have a network that is now carrying a lot of multicast traffic in a single VLAN (CCTV)

We have done a lot of configuration in the network to limit the effects of the multicast traffic, but have just started to have some strange issues.

Basically I have a port that used to have multicast storm control on but it has been removed, but it still gets tripped by storm control randomly at times, this is causing issues of traffic being blocked and dropping of the HSRP between our two main switch stacks.

Any ideas on this?

The enviorment that this is happening in is a Cisco c3750e stack of 4 switches, running IOS 12.2(50)SE3.

Thanks

Matt

8 REPLIES
Community Member

Storm Control issue

Hello Matthew,

Would you be so kind to let us know how did you verify the mcast traffic got limited by storm-control?

Thank you

-- 
Best regards,
Dmitry Skotnikov

-- Best regards, Dmitry Skotnikov
Community Member

Storm Control issue

Hi I see the following in the logs on the switch

STORM_CONTROL-3-FILTERED: A Multicast storm detected on Gi2/0/24. A packet filter action has been applied on the interface.

Thanks

Community Member

Storm Control issue

Hello Matthew,

Would you be so kind to gather the following outputs:

!

show version

show running-config interfaces gi2/0/24

show interfaces gi2/0/24 counters storm-control

!

Thank you

-- 
Best regards,
Dmitry Skotnikov

-- Best regards, Dmitry Skotnikov
Community Member

Re: Storm Control issue

Hi Dmitry

I am unable to run "show interfaces gi2/0/24 counters storm-control" it says it is an invalid command, the others are below.

Show run int gi2/0/24:

interface GigabitEthernet2/0/24

description link to switch-1 Vlan45 only

switchport access vlan 45

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 45

switchport mode trunk

priority-queue out

mls qos trust dscp

no snmp trap link-status

channel-group 6 mode on

spanning-tree portfast

show ver

#show ver
Cisco IOS Software, C3750E Software (C3750E-UNIVERSALK9-M), Version 12.2(50)SE3, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Wed 22-Jul-09 05:35 by prod_rel_team
Image text-base: 0x00003000, data-base: 0x02400000

ROM: Bootstrap program is C3750E boot loader
BOOTLDR: C3750E Boot Loader (C3750E-HBOOT-M) Version 12.2(35r)SE1, RELEASE SOFTWARE (fc2)

PSEWLB044AS3750E-1 uptime is 19 weeks, 3 days, 24 minutes
System returned to ROM by power-on
System restarted at 09:18:15 NZST Sat Apr 27 2013
System image file is "flash:/c3750e-universalk9-mz.122-50.SE3.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

License Level: ipservices
License Type: Permanent
Next reload license Level: ipservices

cisco WS-C3750E-24TD (PowerPC405) processor (revision F0) with 262144K bytes of memory.
Processor board ID FDO1219V1G7
Last reset from power-on
35 Virtual Ethernet interfaces
1 FastEthernet interface
112 Gigabit Ethernet interfaces
4 Ten Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address : 00:1D:70:46:E6:00
Motherboard assembly number : 73-10313-11
Motherboard serial number : FDO12180KGM
Model revision number : F0
Motherboard revision number : A0
Model number : WS-C3750E-24TD-E
Daughterboard assembly number : 800-28590-01
Daughterboard serial number : FDO12170ATP
System serial number : FDO1219V1G7
Top Assembly Part Number : 800-27546-03
Top Assembly Revision Number : A0
Version ID : V02
CLEI Code Number : COMSE00ARA
Hardware Board Revision Number : 0x01


Switch Ports Model SW Version SW Image
------ ----- ----- ---------- ----------
1 28 WS-C3750G-24TS-1U 12.2(50)SE3 C3750-IPSERVICESK9-M
2 28 WS-C3750G-24TS-1U 12.2(50)SE3 C3750-IPSERVICESK9-M
* 3 30 WS-C3750E-24TD 12.2(50)SE3 C3750E-UNIVERSALK9-M
4 30 WS-C3750E-24TD 12.2(50)SE3 C3750E-UNIVERSALK9-M


Switch 01
---------
Switch Uptime : 19 weeks, 3 days, 25 minutes
Base ethernet MAC Address : 00:17:5A:E1:04:00
Motherboard assembly number : 73-9637-08
Power supply part number : 341-0098-01
Motherboard serial number : FOC1011349E
Power supply serial number : DCA1007038G
Model revision number : C0
Motherboard revision number : A0
Model number : WS-C3750G-24TS-E1U
System serial number : FOC1012Y09S
SFP Module assembly part number : 73-7757-03
SFP Module revision number : A0
SFP Module serial number : CAT10081DWL
Top assembly part number : 800-26349-02
Top assembly revision number : B0
Version ID : V02
CLEI Code Number : CNMWZ00ARB

Switch 02
---------
Switch Uptime : 19 weeks, 3 days, 25 minutes
Base ethernet MAC Address : 00:17:5A:E0:C4:80
Motherboard assembly number : 73-9637-08
Power supply part number : 341-0098-01
Motherboard serial number : FOC10113RDW
Power supply serial number : DCA100703B4
Model revision number : C0
Motherboard revision number : A0
Model number : WS-C3750G-24TS-E1U
System serial number : FOC1012Y084
SFP Module assembly part number : 73-7757-03
SFP Module revision number : A0
SFP Module serial number : CAT10070Z81
Top assembly part number : 800-26349-02
Top assembly revision number : B0
Version ID : V02
CLEI Code Number : CNMWZ00ARB

Switch 04
---------
Switch Uptime : 19 weeks, 3 days, 24 minutes
Base ethernet MAC Address : 9C:AF:CA:2F:4B:80
Motherboard assembly number : 73-11177-13
Motherboard serial number : FDO13481411
Model revision number : G0
Motherboard revision number : A0
Model number : WS-C3750E-24TD-S
Daughterboard assembly number : 800-29737-01#
Daughterboard serial number : FDO134712HE
System serial number : FDO1348R1SX
Top assembly part number : 800-28924-01#
Top assembly revision number : C0
Version ID : V03
CLEI Code Number : COMSE00ARB
License Level : ipbase
License Type : Permanent
Next reboot licensing Level : ipbase


Configuration register is 0xF

Community Member

Storm Control issue

Hello Matthew,

I can see the port is a part of GEC, would you be so kind to capture the following:

show etherchannel 6 summary

show running-config int po6

show storm-control po6 multicast

show storm-control gi2/0/24 multicast

Thank you

-- 
Best regards,
Dmitry Skotnikov

-- Best regards, Dmitry Skotnikov
Community Member

Re: Storm Control issue

Hi Dmitry

show etherchannel 6 summary:

Number of channel-groups in use: 2
Number of aggregators: 2

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
6 Po6(SU) - Gi2/0/24(P) Gi3/0/4(P)

show running-config int po6:

interface Port-channel6

description link to switch-1 Vlan45 only

switchport access vlan 45

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 45

switchport mode trunk

no snmp trap link-status

spanning-tree portfast

show storm-control po6 multicast:

Invalid input detected^

#show storm-control gi2/0/24 multicast

Interface Filter State Upper Lower Current

--------- ------------- ----------- ----------- ----------

Community Member

Re: Storm Control issue

Hello Matthew,

That's unclear where the messages come from, without storm-control configured. How often do you receive the messages on the box and are there another boxes with similar behavior?

-- 
Best regards,
Dmitry Skotnikov

-- Best regards, Dmitry Skotnikov
Community Member

Re: Storm Control issue

Hi Dmitry,

Thus my problem, we do not have it configured on this port, we do rescive the messages randomly, when it does happen, it normaly happens a few times in a row. We do have storm control configured on other ports and it is working as expected. This is the only port that we get this on that does not have storm control configured.

Thanks

Matt

508
Views
0
Helpful
8
Replies
CreatePlease to create content