Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

STP guard root

Hello,

Recently we've had a situation where we have two ports connected via Gig fiber uplink and for some reason the second switch loses connection with switch one and to get it back we have to go into switch two and do "shut, no shut"

There are 3 switches total, I'm wondering about the spanning-tree guard root command not on switch1--switch2 link as we have it on uplink ports to switch 3 and switch 4 and the have no issues. Here is the configs on each:

Switch one

=============

interface GigabitEthernet0/1
description *** UPLINK TO SW#2 ***
switchport trunk encapsulation dot1q
switchport trunk pruning vlan 5
switchport mode trunk
ip arp inspection trust
udld port aggressive
ip dhcp snooping trust

!

interface FastEthernet0/43
description *** UPLINK TO SW3 ***  (No link problems)
switchport trunk encapsulation dot1q
switchport trunk pruning vlan 5
switchport mode trunk
ip arp inspection trust
priority-queue out
udld port aggressive
spanning-tree guard root
ip dhcp snooping trust
!
interface FastEthernet0/44
description *** UPLINK TO SW4 *** (No link problems)
switchport trunk encapsulation dot1q
switchport trunk pruning vlan 5
switchport mode trunk
ip arp inspection trust
priority-queue out
udld port aggressive
spanning-tree guard root
ip dhcp snooping trust

Switch two

============

interface GigabitEthernet0/1     (uplink to switch one)
switchport trunk encapsulation dot1q
switchport trunk pruning vlan 5
switchport mode trunk
ip arp inspection trust
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
udld port aggressive
mls qos trust dscp
auto qos voip trust
ip dhcp snooping trust
!

If I place spanning-tree guard root on Sw1-Gig0/1 will that work? Is it possible that swtich one is receiving a superior BPDU and shuts the port down?

Here is the log message we see when this happens:

MST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to down

Thanks.

3 REPLIES
New Member

Re: STP guard root

Correction: There are 4 switches total :

Switch one(root) ------switch two

            |  |---------------switch three

            |------------------switch four

Cisco Employee

Re: STP guard root

Hi,

Could you please paste the logs from SW 2 when it is going down.. A current show log might also help. Root guard is probably not the issue here.

Rgds,
Souvik

New Member

Re: STP guard root

Here is the log from SW#2, I had to do a shut/no shut on gig0/1 to get the link back:

001341: Sep 22 10:07:21.487 CDT: %SYS-2-MALLOCFAIL: Memory allocation of 756 bytes failed from 0x2D0178, alignment 0
Pool: I/O  Free: 11476  Cause: Memory fragmentation
Alternate Pool: None  Free: 0  Cause: No Alternate pool
-Process= "DHCP Snooping", ipl= 0, pid= 179
-Traceback= DF3974 DF40C0 1880A7C 1882F9C 1883110 2D017C 2D05CC 2D0D14 2CF2EC 2CF76C 98B704 E501E4 E5073C A2E4C8 A24F98
001346: Sep 22 10:08:22.632 CDT: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to down

270
Views
0
Helpful
3
Replies
CreatePlease to create content