Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

STP issue for multihoming workstation

Hi,

I have 1 windows XP workstation connecting 2 switches on separate network.

Let call the 2 switches - Switch 1 & switch 2

I found that bpdu packet has been porpagate from switch 1 to switch 2 through my windows xp workstation.

My windows XP workstation IP address,

NIC 1

IP :192.168.7.1

Subnet : 255.255.255.0

Gateway: 192.168.7.254

NIC2

IP : 10.3.1.100

Subnet: 255.255.255.240

Gateway : none

In this case, any idea on how to prevent spanning-tree protocol (bpdu) porpogate from switch 1 to Switch 2 thorugh my windows XP workstation?

Thks in advance.

Regards,

Steven

3 REPLIES
Cisco Employee

Re: STP issue for multihoming workstation

Hi Steven,

Can you confirm the port on switch 1 an switch 2 on which your nic cards are connected are in seperate vlan or same vlan?

Regards,

Ankur

Community Member

Re: STP issue for multihoming workstation

Hi Ankur,

The 2 switches are in separate network. Physically there is not any connection between this 2 switches. This 2 switches connect to each other only through the windows XP workstation.

Workstation NIC 1 connect to switch 1 in vlan 7, NIC 2 connect to switch 2 in vlan 5

Port config for Switch 1,

interface GigabitEthernet2/0/2

switchport access vlan 7

switchport mode access

storm-control broadcast level 5.00

storm-control action trap

spanning-tree portfast

spanning-tree bpduguard enable

!

Port Config for Switch 2,

interface GigabitEthernet1/48

switchport

switchport access vlan 5

switchport mode access

no ip address

storm-control broadcast level 5.00

no cdp enable

spanning-tree portfast

spanning-tree bpduguard enable

end

regards,

Steven

Bronze

Re: STP issue for multihoming workstation

strange that bpdu is propagating..

now 4rm config ,portfast and bpdu guard doent prevent sending bpdus..u must configure bpdu filter for the same..

and also doesnt ur sw's creating any problem when its receiving bpdu's as u have configured both portfast and bpduguard??

483
Views
0
Helpful
3
Replies
CreatePlease to create content