Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

STP issue

Hi all,

We are having an issue configuring the Spanning protocol on the topology shown in the attached picture. I will try to explain the situation:

     - The 4510 of the old building is forced to be the root bridge of the topology (spanning-tree vlan 1-1001 priority 4096)

     - The 10 Gb optical fiber is redundant

     - The wifi bridge should only be used in case of the 10Gb optical fiber stops working.

In order to configure this we have configured the following:

     - The cost of the interfaces of the two switch stacks where the wifi bridge is connected has been modified:

               spanning-tree vlan 1-1001 cost 100

In this situation we can see the following:

     - The port on the switch stack of the old building gets Blocked (BLK) --> OK, all the traffic goes through the optical fiber

     - On the 4507 of the new building we can see one of the TenGigabit interface blocked for all the vlans, while the other is forwarding --> OK

      - If we make a shutdown on the TenGibabit interface which is forwarding:

               - The interface of the wifi bridge is still blocked --> OK

               - On the 4507 the TenGigabit interface which was blocked goes to forwarding status --> OK

     - If we make a no shutdown, everything recovers OK.

     - If we make a shutdown on both TenGigabit interface:

               - The interface where the wifi bridge is connected gets unblocked (Role Root, Status forwarding) --> OK

     - If we make a no shutdown on both TenGigabit interface:

               - On the 4507 of the new building one of the TenGigabit interfaces gets blocked and the other one forwarding -->OK

               - On the switch of the new building where the wifi bridge is connected: designated and forwarding --> OK

               - The interface of the switch of the old building where the wifi bridge is connected does not get blocked --> WRONG!!

In this last situation, we cannot see it by making "show spanning-tree blockedports". We have to make a "shutdown" and a "no shutdown" on this interface in order to see it again as blocked, by making the "show spanning-tree blockedports" command. Shouldn't this be automatic when go make a "no shutdown" on the TenGigabit interfaces?

Where could be the problem? The 4510 has an older IOS, 12.2(25)SG2.

Any help will be appreciated!!

Thanks in advance!!



187
Views
0
Helpful
0
Replies