Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

STP on uplinks

I have two 6509's that are port-channeled together.  I want each 6509 to provide uplinks to a single 4509.  The problem is that STP keeps blocking all the interface on one of  my 6509's.  Is there a way to have both uplinks up at the same time?

3 REPLIES
Hall of Fame Super Blue

Re: STP on uplinks

Jonathancert wrote:

I have two 6509's that are port-channeled together.  I want each 6509 to provide uplinks to a single 4509.  The problem is that STP keeps blocking all the interface on one of  my 6509's.  Is there a way to have both uplinks up at the same time?


No unless you use VSS on the 6500 switches which would require the correct supervisor and linecards. If you don't use VSS then one link has to block because you have a L2 loop, assuming your 6500 interconnect is a L2 trunk.

VSS would allow you to spread the same etherchannel across both 6500 chassis and have all links forwarding.

Without VSS you could -

1) load-balance the vlans if you have multiple vlans on the 4500. So you set the STP root for odd vlans to 6500_1 and the STP root for even vlans to 6500_2. If you do this you should also match up the HSRP active and standy routers.

2) make the port-channel between the 6500 switches a L3 etherchannel then you have broken the L2 loop and both uplinks would forward. However you can't simply just do this, you need to understand the effects on your whole network and it would probably need some redesign.

Jon

Community Member

Re: STP on uplinks

I have the 6509's set up with odd and even VLANs.  So i may be missing a vital config on my port-channel for layer 3.

interface Port-channel10
description DSW1 - DSW2
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport trunk allowed vlan 999

interface TenGigabitEthernet1/7
description DSW1 to DSW2
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport trunk allowed vlan 999
switchport mode trunk
channel-group 10 mode on

interface TenGigabitEthernet2/7
description DSW1 to DSW2
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport trunk allowed vlan 999
switchport mode trunk
channel-group 10 mode on

interface Vlan999
description DSW1 to DSW2

ip address 172.16.45.126 255.255.255.254  *DSW2 ip is 172.16.45.127 255.255.255.254*
no ip redirects
ip ospf network point-to-point

Hall of Fame Super Blue

Re: STP on uplinks

Jonathancert wrote:

I have the 6509's set up with odd and even VLANs.  So i may be missing a vital config on my port-channel for layer 3.

interface Port-channel10
description DSW1 - DSW2
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport trunk allowed vlan 999

interface TenGigabitEthernet1/7
description DSW1 to DSW2
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport trunk allowed vlan 999
switchport mode trunk
channel-group 10 mode on

interface TenGigabitEthernet2/7
description DSW1 to DSW2
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport trunk allowed vlan 999
switchport mode trunk
channel-group 10 mode on

interface Vlan999
description DSW1 to DSW2

ip address 172.16.45.126 255.255.255.254  *DSW2 ip is 172.16.45.127 255.255.255.254*
no ip redirects
ip ospf network point-to-point

Is this the interconnect between the 2 6500 switches. If so a couple of things -

1) the above is not a L3 link, it is a L2 trunk which only allows vlan 999

2) following on from 1) only vlan 999 should be blocking on one of the uplinks.

Perhaps you could pick vlan on the 4500 switches that is blocking on one of the uplinks and then from the 4500 and both 6500 switches post a - "sh spanning-tree vlan

Jon

271
Views
0
Helpful
3
Replies
CreatePlease to create content