Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

STP problem on vlan 1 in a heterogeneous network.

Hello,

we have an heterogeneous network with Cisco devices (6509-E, 3750G and 3560) and Alcatel 6850 devices. We have to enable a PTP Wifi line as a backup for the fiber line between two buildings. For this purpose, we have connected a wifi device to GigabitEthernet 0/47 of SWIHGJ1 and configured it as:

SWIHGJ1#show running-config interface GigabitEthernet 0/47

Building configuration...

Current configuration : 298 bytes

!

interface GigabitEthernet0/47

description Antena WiMax HG

power inline never

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,4-6,9-15,24,51,1002-1005

switchport mode trunk

switchport nonegotiate

shutdown

spanning-tree port-priority 176

spanning-tree cost 100

end

I enclose you a topology picture to ilustrate this.

When we enable this interface, all VLANs are blocked except VLAN 1 that produces a loop into the network.

SWIHGJ1#

SWIHGJ1#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

SWIHGJ1(config)#int gi0/47

SWIHGJ1(config-if)#

SWIHGJ1(config-if)#do sh run int gi 0/47

Building configuration...

Current configuration : 298 bytes

!

interface GigabitEthernet0/47

description Antena WiMax HG

power inline never

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,4-6,9-15,24,51,1002-1005

switchport mode trunk

switchport nonegotiate

shutdown

spanning-tree port-priority 176

spanning-tree cost 100

end

SWIHGJ1(config-if)#

SWIHGJ1(config-if)#

SWIHGJ1(config-if)#do sh span blocked

Name                 Blocked Interfaces List

-------------------- ------------------------------------

Number of blocked ports (segments) in the system : 0

SWIHGJ1(config-if)#

SWIHGJ1(config-if)#

SWIHGJ1(config-if)#no shut

SWIHGJ1(config-if)#

SWIHGJ1(config-if)#

SWIHGJ1(config-if)#

SWIHGJ1(config-if)#

3877112: Aug 13 22:24:01.751 UTC: %LINK-3-UPDOWN: Interface GigabitEthernet0/47, changed state to down

3877113: Aug 13 22:24:02.313 UTC: set portid: VLAN0001 Gi0/47: new port id B02F

3877114: Aug 13 22:24:02.313 UTC: STP SW: Gi0/47 new blocking req for 1 vlans

3877115: Aug 13 22:24:02.313 UTC: STP: VLAN0001 Gi0/47 -> listening

3877116: Aug 13 22:24:02.313 UTC: set portid: VLAN0002 Gi0/47: new port id B02F

3877117: Aug 13 22:24:02.313 UTC: STP: VLAN0002 Gi0/47 -> listening

3877118: Aug 13 22:24:02.313 UTC: set portid: VLAN0004 Gi0/47: new port id B02F

3877119: Aug 13 22:24:02.313 UTC: STP: VLAN0004 Gi0/47 -> listening

3877120: Aug 13 22:24:02.313 UTC: set portid: VLAN0005 Gi0/47: new port id B02F

3877121: Aug 13 22:24:02.313 UTC: STP: VLAN0005 Gi0/47 -> listening

3877122: Aug 13 22:24:02.313 UTC: set portid: VLAN0006 Gi0/47: new port id B02F

3877123: Aug 13 22:24:02.313 UTC: STP: VLAN0006 Gi0/47 -> listening

3877124: Aug 13 22:24:02.313 UTC: set portid: VLAN0009 Gi0/47: new port id B02F

3877125: Aug 13 22:24:02.313 UTC: STP: VLAN0009 Gi0/47 -> listening

3877126: Aug 13 22:24:02.321 UTC: set portid: VLAN0010 Gi0/47: new port id B02F

3877127: Aug 13 22:24:02.321 UTC: STP: VLAN0010 Gi0/47 -> listening

3877128: Aug 13 22:24:02.321 UTC: set portid: VLAN0011 Gi0/47: new port id B02F

3877129: Aug 13 22:24:02.321 UTC: STP: VLAN0011 Gi0/47 -> listening

3877130: Aug 13 22:24:02.321 UTC: set portid: VLAN0012 Gi0/47: new port id B02F

3877131: Aug 13 22:24:02.321 UTC: STP: VLAN0012 Gi0/47 -> listening

3877132: Aug 13 22:24:02.321 UTC: set portid: VLAN0013 Gi0/47: new port id B02F

3877133: Aug 13 22:24:02.321 UTC: STP: VLAN0013 Gi0/47 -> listening

3877134: Aug 13 22:24:02.321 UTC: set portid: VLAN0014 Gi0/47: new port id B02F

3877135: Aug 13 22:24:02.321 UTC: STP: VLAN0014 Gi0/47 -> listening

3877136: Aug 13 22:24:02.321 UTC: set portid: VLAN0015 Gi0/47: new port id B02F

3877137: Aug 13 22:24:02.321 UTC: STP: VLAN0015 Gi0/47 -> listening

3877138: Aug 13 22:24:02.321 UTC: set portid: VLAN0024 Gi0/47: new port id B02F

3877139: Aug 13 22:24:02.321 UTC: STP: VLAN0024 Gi0/47 -> listening

3877140: Aug 13 22:24:02.321 UTC: set portid: VLAN0051 Gi0/47: new port id B02F

3877141: Aug 13 22:24:02.321 UTC: STP: VLAN0051 Gi0/47 -> listening

3877142: Aug 13 22:24:04.217 UTC: STP SW: Gi0/47 new blocking req for 1 vlans

3877143: Aug 13 22:24:04.217 UTC: STP: VLAN0011 Gi0/47 -> blocking

3877144: Aug 13 22:24:04.217 UTC: STP SW: Gi0/47 new blocking req for 1 vlans

3877145: Aug 13 22:24:04.217 UTC: STP: VLAN0012 Gi0/47 -> blocking

3877146: Aug 13 22:24:04.217 UTC: STP SW: Gi0/47 new blocking req for 1 vlans

3877147: Aug 13 22:24:04.217 UTC: STP: VLAN0013 Gi0/47 -> blocking

3877148: Aug 13 22:24:04.217 UTC: STP: VLAN0014 Gi0/47 -> blocking

3877149: Aug 13 22:24:04.225 UTC: STP: VLAN0015 Gi0/47 -> blocking

3877150: Aug 13 22:24:04.225 UTC: STP: VLAN0024 Gi0/47 -> blocking

3877151: Aug 13 22:24:04.225 UTC: STP: VLAN0051 Gi0/47 -> blocking

3877152: Aug 13 22:24:04.284 UTC: %LINK-3-UPDOWN: Interface GigabitEthernet0/47, changed state to up

3877153: Aug 13 22:24:05.014 UTC: STP SW: Gi0/47 new blocking req for 1 vlans

3877154: Aug 13 22:24:05.014 UTC: STP: VLAN0002 Gi0/47 -> blocking

3877155: Aug 13 22:24:05.014 UTC: STP: VLAN0004 Gi0/47 -> blocking

3877156: Aug 13 22:24:05.014 UTC: STP: VLAN0005 Gi0/47 -> blocking

3877157: Aug 13 22:24:05.014 UTC: STP: VLAN0006 Gi0/47 -> blocking

3877158: Aug 13 22:24:05.014 UTC: STP: VLAN0009 Gi0/47 -> blocking

3877159: Aug 13 22:24:05.014 UTC: STP: VLAN0010 Gi0/47 -> blocking

3877160: Aug 13 22:24:05.291 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/47, changed state to up

SWIHGJ1(config-if)#

SWIHGJ1(config-if)#

SWIHGJ1(config-if)#

SWIHGJ1(config-if)#do sh spanning-tree blocked

Name                 Blocked Interfaces List

-------------------- ------------------------------------

VLAN0002             Gi0/47

VLAN0004             Gi0/47

VLAN0005             Gi0/47

VLAN0006             Gi0/47

VLAN0009             Gi0/47

VLAN0010             Gi0/47

VLAN0011             Gi0/47

VLAN0012             Gi0/47

VLAN0013             Gi0/47

VLAN0014             Gi0/47

VLAN0015             Gi0/47

VLAN0024             Gi0/47

VLAN0051             Gi0/47

Number of blocked ports (segments) in the system : 13

SWIHGJ1(config-if)#

3877161: Aug 13 22:24:17.320 UTC: STP SW: Gi0/47 new learning req for 1 vlans

3877162: Aug 13 22:24:17.320 UTC: STP: VLAN0001 Gi0/47 -> learning

SWIHGJ1(config-if)#

SWIHGJ1(config-if)#

3877163: Aug 13 22:24:25.977 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 0026.0a25.8f00 in vlan 1 is flapping between port Gi0/47 and port Po1

SWIHGJ1(config-if)#

SWIHGJ1(config-if)#do sh spanning-tree blocked

Name                 Blocked Interfaces List

-------------------- ------------------------------------

VLAN0002             Gi0/47

VLAN0004             Gi0/47

VLAN0005             Gi0/47

VLAN0006             Gi0/47

VLAN0009             Gi0/47

VLAN0010             Gi0/47

VLAN0011             Gi0/47

VLAN0012             Gi0/47

VLAN0013             Gi0/47

VLAN0014             Gi0/47

VLAN0015             Gi0/47

VLAN0024             Gi0/47

VLAN0051             Gi0/47

Number of blocked ports (segments) in the system : 13

SWIHGJ1(config-if)#

3877164: Aug 13 22:24:32.327 UTC: STP SW: Gi0/47 new forwarding req for 1 vlans

3877165: Aug 13 22:24:32.327 UTC: STP: VLAN0001 sent Topology Change Notice on Po1

3877166: Aug 13 22:24:32.327 UTC: STP: VLAN0001 Gi0/47 -> forwarding

3877167: Aug 13 22:24:32.713 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 0026.0a24.6140 in vlan 1 is flapping between port Gi0/47 and port Po1

3877168: Aug 13 22:24:33.904 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 0026.0a25.8f00 in vlan 1 is flapping between port Po1 and port Gi0/47

SWIHGJ1(config-if)#

SWIHGJ1(config-if)#do sh spanning-tree blocked

3877178: Aug 13 22:24:45.170 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 000f.2066.a100 in vlan 1 is flapping between port Po1 and port Gi0/47

Name                 Blocked Interfaces List

-------------------- ------------------------------------

VLAN0002             Gi0/47

VLAN0004             Gi0/47

VLAN0005             Gi0/47

VLAN0006             Gi0/47

VLAN0009             Gi0/47

VLAN0010             Gi0/47

VLAN0011             Gi0/47

VLAN0012             Gi0/47

VLAN0013             Gi0/47

VLAN0014             Gi0/47

VLAN0015             Gi0/47

VLAN0024             Gi0/47

VLAN0051             Gi0/47

Number of blocked ports (seg

3877179: Aug 13 22:24:46.236 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 0026.0a25.8f00 in vlan 1 is flapping between port Po1 and port Gi0/47

3877180: Aug 13 22:24:46.236 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 000d.9df5.ments) in the system : 13

SWIHGJ1(config-if)#

SWIHGJ1(config-if)#

SWIHGJ1(config-if)#7c00 in vlan 1 is flapping between port Po1 and port Gi0/47

3877181: Aug 13 22:24:46.286 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 000f.2066.a100 in vlan 1 is flapping between port Gi0/47 and port Po1

3877182: Aug 13 22:24:53.651 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 0026.0a24.6140 in vlan 1 is flapping between port Gi0/47 and port Po1

3877183: Aug 13 22:25:01.520 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 0026.0a25.8f00 in vlan 1 is flapping between port Gi0/47 and port Po1

3877184: Aug 13 22:25:07.493 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 00d0.95e3.cd44 in vlan 1 is flapping between port Gi0/47 and port Po1

3877185: Aug 13 22:25:08.147 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 00e0.b1a2.5ade in vlan 1 is flapping between port Gi0/47 and port Po1

3877186: Aug 13 22:25:11.746 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 0026.0a24.6140 in vlan 1 is flapping between port Gi0/47 and port Po1

3877187: Aug 13 22:25:12.970 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 00e0.b19a.4008 in vlan 1 is flapping between port Gi0/47 and port Po1

SWIHGJ1(config-if)#

Could you please, help us with this issue?.

Best regards.

Antonio de la Chica.

Everyone's tags (1)
2 REPLIES
Green

STP problem on vlan 1 in a heterogeneous network.

Antonio,

You only seem to see the STP looping problem with VLAN 1.

With the interface shut try and find out where the root bridge for VLAN 1 resides and compare to other good VLANs like 2 etc.

You could also try changing the stp prt cost to an extreme number like "spanning-tree cost 5000"

just to test.

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
New Member

Re: STP problem on vlan 1 in a heterogeneous network.

Hello Alex,

thank you very much for your quick response.

You're right my spanning-tree loop is only at vlan 1, as you can check into the following "show spanning-tree" command output during a loop:

3876992: Aug 13 21:33:22.323 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 001c.c58a.9020 in vlan 1 is flapping between port Gi0/47 and port Po1

3876993: Aug 13 21:33:22.323 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 00e0.b1a2.5ade in vlan 1 is flapping between port Gi0/47 and port Po1

3876994: Aug 13 21:33:23.740 UTC: %SW_MATM-4-MACFLAP_NOTIF: Host 0026.0a24.6140 in vlan 1 is flapping between port Po1 and port Gi0/47   

SWIHGJ1#  sh span

VLAN0001

  Spanning tree enabled protocol ieee

  Root ID    Priority    1

             Address     0026.0a24.6140

             Cost        8

             Port        56 (Port-channel1)

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)

             Address     0027.0c6c.9e80

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

             Aging Time 15

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Gi0/47           Desg FWD 100       176.47   P2p

Gi0/48           Desg FWD 4         128.48   P2p

Po1              Root FWD 4         128.56   P2p

VLAN0002

  Spanning tree enabled protocol ieee

  Root ID    Priority    2

             Address     0026.0a24.6140

             Cost        8

             Port        56 (Port-channel1)

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32770  (priority 32768 sys-id-ext 2)

             Address     0027.0c6c.9e80

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

             Aging Time 15

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Gi0/1            Desg FWD 4         128.1    Edge P2p

Gi0/2            Desg FWD 4         128.2    Edge P2p

Gi0/3            Desg FWD 4         128.3    Edge P2p

Gi0/4            Desg FWD 4         128.4    Edge P2p

Gi0/5            Desg FWD 4         128.5    Edge P2p

Gi0/7            Desg FWD 19        128.7    Edge P2p

Gi0/8            Desg FWD 4         128.8    Edge P2p

Gi0/9            Desg FWD 100       128.9    Edge P2p

Gi0/10           Desg FWD 4         128.10   Edge P2p

Gi0/11           Desg FWD 4         128.11   Edge P2p

Gi0/12           Desg FWD 100       128.12   Edge P2p

Gi0/13           Desg FWD 19        128.13   Edge Shr

Gi0/14           Desg FWD 19        128.14   Edge P2p

Gi0/20           Desg FWD 4         128.20   Edge P2p

Gi0/24           Desg FWD 19        128.24   Edge P2p

Gi0/25           Desg FWD 19        128.25   Edge P2p

Gi0/27           Desg FWD 19        128.27   Edge P2p

Gi0/28           Desg FWD 19        128.28   Edge P2p

Gi0/29           Desg FWD 4         128.29   Edge P2p

Gi0/30           Desg FWD 4         128.30   Edge P2p

Gi0/31           Desg FWD 100       128.31   Edge P2p

Gi0/32           Desg FWD 4         128.32   Edge P2p

Gi0/33           Desg FWD 4         128.33   Edge P2p

Gi0/34           Desg FWD 4         128.34   Edge P2p

Gi0/35           Desg FWD 100       128.35   Edge P2p

Gi0/37           Desg FWD 19        128.37   Edge Shr

Gi0/47           Altn BLK 100       176.47   P2p

Gi0/48           Desg FWD 4         128.48   P2p

Po1              Root FWD 4         128.56   P2p

       

VLAN0004

  Spanning tree enabled protocol ieee

  Root ID    Priority    4

             Address     0026.0a24.6140

             Cost        8

             Port        56 (Port-channel1)

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32772  (priority 32768 sys-id-ext 4)

             Address     0027.0c6c.9e80

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

             Aging Time 15

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Gi0/47           Altn BLK 100       176.47   P2p

Po1              Root FWD 4         128.56   P2p

The rest of VLANs has the same result and it is the same topology with this interface shutted down.

Finally, I'll try to increment this interface cost to 5000 as you suggest and I'll tell you the result.

Thank you very much for your help.

Antonio.

728
Views
0
Helpful
2
Replies
CreatePlease to create content