Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

STP problem with PC + IP phone connection on WS-C3750X-48P

Hello all,

Here is the hardware configuration:

Switch Ports Model              SW Version            SW Image                

------ ----- -----              ----------            ----------              

     1 54    WS-C3750X-48P      12.2(53)SE2           C3750E-UNIVERSALK9-M    

*    2 30    WS-C3750X-24P      12.2(53)SE2           C3750E-UNIVERSALK9-M

Here is the part of the configuration :

!

spanning-tree mode rapid-pvst

spanning-tree portfast bpduguard default

spanning-tree etherchannel guard misconfig

spanning-tree extend system-id

!

....

!

interface GigabitEthernet1/0/17

description IPT+PC                                     

switchport access vlan 10

switchport voice vlan 845

logging event spanning-tree

logging event status

priority-queue out

udld port

no snmp trap link-status

no cdp enable

spanning-tree portfast

service-policy input IPPHONE+PC

!

PC + Alcatel ip phone is connected to the port 1/0/17.

We are not able to establish connection over the GigabitEthernet1/0/17 and we are still getting the following error messages :

640138: Nov 10 12:37:07.850 UTC: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/17, changed state to down

052494: Nov 10 12:37:07.386 UTC: %ILPOWER-7-DETECT: Interface Gi1/0/17: Power Device detected: IEEE PD (switch1)

052495: Nov 10 12:37:07.990 UTC: %ILPOWER-5-POWER_GRANTED: Interface Gi1/0/17: Power granted (switch1)

052496: Nov 10 12:37:10.464 UTC: %SPANTREE-6-PORT_STATE: Port Gi1/0/17 instance 10 moving from disabled to blocking (switch1)

052497: Nov 10 12:37:10.464 UTC: %SPANTREE-6-PORT_STATE: Port Gi1/0/17 instance 10 moving from blocking to forwarding (switch1)

052498: Nov 10 12:37:10.464 UTC: %SPANTREE-6-PORT_STATE: Port Gi1/0/17 instance 845 moving from disabled to blocking (switch1)

052499: Nov 10 12:37:10.464 UTC: %SPANTREE-6-PORT_STATE: Port Gi1/0/17 instance 845 moving from blocking to forwarding (switch1)

640139: Nov 10 12:37:12.438 UTC: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/17, changed state to up

640140: Nov 10 12:37:13.444 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/17, changed state to up

640141: Nov 10 12:37:13.553 UTC: %SYS-5-CONFIG_I: Configured from console by sgrpsst1 on vty0 (10.105.209.89)

052500: Nov 10 12:37:13.795 UTC: %SPANTREE-6-PORT_STATE: Port Gi1/0/17 instance 10 moving from forwarding to disabled (switch1)

052501: Nov 10 12:37:13.795 UTC: %SPANTREE-7-PORTDEL_SUCCESS: GigabitEthernet1/0/17 deleted from Vlan 10 (switch1)

052502: Nov 10 12:37:13.803 UTC: %SPANTREE-6-PORT_STATE: Port Gi1/0/17 instance 845 moving from forwarding to disabled (switch1)

052503: Nov 10 12:37:13.803 UTC: %SPANTREE-7-PORTDEL_SUCCESS: GigabitEthernet1/0/17 deleted from Vlan 845 (switch1)

640142: Nov 10 12:37:14.820 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/17, changed state to down

640143: Nov 10 12:37:15.969 UTC: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/17, changed state to down

052504: Nov 10 12:37:16.370 UTC: %SPANTREE-6-PORT_STATE: Port Gi1/0/17 instance 10 moving from disabled to blocking (switch1)

052505: Nov 10 12:37:16.370 UTC: %SPANTREE-6-PORT_STATE: Port Gi1/0/17 instance 10 moving from blocking to forwarding (switch1)

052506: Nov 10 12:37:16.370 UTC: %SPANTREE-6-PORT_STATE: Port Gi1/0/17 instance 845 moving from disabled to blocking (switch1)

052507: Nov 10 12:37:16.370 UTC: %SPANTREE-6-PORT_STATE: Port Gi1/0/17 instance 845 moving from blocking to forwarding (switch1)

640144: Nov 10 12:37:18.435 UTC: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/17, changed state to up

640145: Nov 10 12:37:19.442 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/17, changed state to up

switch#          

switch#sh mac-address int gi1/0/17

          Mac Address Table

-------------------------------------------

Vlan    Mac Address       Type        Ports

----    -----------       --------    -----

switch#

Somebody have any Idea where the problem is ?

Thank you.

6 REPLIES
Bronze

STP problem with PC + IP phone connection on WS-C3750X-48P

Hi,

I think that these messages are not really error messages.

It should be the normal behavior of spanning-tree when a port comes up (disabled -> blocking -> forwarding) and goes down. You can see, the severity level is 6 and 7, so these are debugging and informational messages and not errors.

Did you try to configure the speed/duplex with fixed values on the switch? Maybe the phone has a problem with auto sensing.

You can set the port as an fixed access port by using "switchport mode access". But I don't believe that this is the reason for your problems. It is only better config style ;-)

I can't test this because I don't have Alcatel phones here.

Sven

New Member

STP problem with PC + IP phone connection on WS-C3750X-48P

Hello,

I have tried to change speed an duplex  to 100 and full but without success.

The ip phone didn't get any IP from DHCP,  no mac address learnt, no input traffic on that interface.

It's really weird.

switch1#sh mac address-table int gi1/0/17

          Mac Address Table

-------------------------------------------

Vlan    Mac Address       Type        Ports

----    -----------       --------    -----

switch1#sh int gi1/0/17

GigabitEthernet1/0/17 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 588d.0946.c511 (bia 588d.0946.c511)

  Description: IPT+PC                                        

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 29w1d, output 3w5d, output hang never

  Last clearing of "show interface" counters 05:09:24

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     117546 packets output, 16734486 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

switch1#sh run int gi1/0/17

Building configuration...

Current configuration : 383 bytes

!

interface GigabitEthernet1/0/17

description IPT+PC                                        

switchport access vlan 10

switchport mode access

switchport voice vlan 845

logging event spanning-tree

logging event status

speed 100

duplex full

priority-queue out

udld port

no snmp trap link-status

no cdp enable

spanning-tree portfast

service-policy input IPPHONE+PC

end

Hmmm.......any suggestions ?

Thank you

Bronze

STP problem with PC + IP phone connection on WS-C3750X-48P

Did you try to connect the phone with a fixed ip address? So it would be possible to narrow down the problem.

If there is no input traffic on the interface I think there is no DHCP request from the phone.

To exclude the DHCP it would be best to manually configure the address.

Sven

New Member

STP problem with PC + IP phone connection on WS-C3750X-48P

Tried with fixed IP address but no luck. The interface is still not transmitting any packets:

r2-demun-a59-00-swx-d#sh int gi1/0/17

GigabitEthernet1/0/17 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 588d.0946.c511 (bia 588d.0946.c511)

Description: IPT+PC

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 29w3d, output 4w0d, output hang never

Last clearing of "show interface" counters 2d06h

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts (0 multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

0 input packets with dribble condition detected

1058740 packets output, 151455941 bytes, 0 underruns

0 output errors, 0 collisions, 4 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

r2-demun-a59-00-swx-d#sh mac ad

r2-demun-a59-00-swx-d#sh mac address-table int gi1/0/17

Mac Address Table

-------------------------------------------

Vlan Mac Address Type Ports

---- ----------- -------- -----

Bronze

Re: STP problem with PC + IP phone connection on WS-C3750X-48P

Hi Daniel,

Could you please try this:

1. Try removing "udld port" command on your interface..... and see what happens.

2. Though you have alcatel ip phone connected, can you please enable cdp once and see if it still behaves same.

3. And then, can you try disabling portfast on the interface and test the behaviour please?

And, could you please let us know

1. What type of cable has been connected between your IP phone and the switch ??

2. What is the model of the ip phone you have connected?

Thanks.

New Member

Re: STP problem with PC + IP phone connection on WS-C3750X-48P

Cisco TAC SR has been raised and the problem was identified as hardware failure. Switch will be replaced.

776
Views
0
Helpful
6
Replies
CreatePlease login to create content