Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Strange config behaviour on 3560 switch

Hi

I've got some strange conflict occurring on my switch configuration. This is a new switch that's currently being configured, its a 3560 switch.

While setting up the switch I created the following vlan interface:

interface Vlan10

ip address 10.100.1.2 255.255.255.0

ip helper-address 10.1.1.3

standby 1 ip 10.1.3.1

standby 1 priority 120

standby 1 preempt

standby 2 ip 10.100.1.1

standby 2 priority 120

standby 2 preempt

The "2" portion of the hsrp config was copied into vlan 10 by mistake. I removed it by issuing "no" statements before then pressed "Ctrl-Z", I verified the config on vlan 10, so I now have:

interface Vlan10

ip address 10.1.1.2 255.255.255.0

ip helper-address 10.1.1.3

standby 1 ip 10.1.3.1

standby 1 priority 120

standby 1 preempt

I then created a new vlan interface vlan 20 and copied the following lines in:

interface Vlan200

ip address 10.100.1.2 255.255.255.0

ip helper-address 10.1.1.3

standby 2 ip 10.100.1.1

standby 2 priority 120

standby 2 preempt

Now the once I copied those in I get the following errors:

10.100.1.0 overlaps with Vlan10

10.100.1.1 overlaps with Vlan10

Now this is strange, as vlan 10 no longer contains these subnet statements, so my question is why is the switch getting confused, and how can fix the problem?

Thanks in advance

Dan

2 REPLIES
New Member

Re: Strange config behaviour on 3560 switch

wr mem

reload

Sometimes devices retain configuration even after issuing no statements, in these cases the device must be reloaded to clear the stale lines.

Hall of Fame Super Bronze

Re: Strange config behaviour on 3560 switch

Since you are implementing HSRP, I'm assuming you have another router/switch with a similar config, did you check you eliminated the 10.100.1.1 from that switch's Vlan10 as well ?

119
Views
0
Helpful
2
Replies
CreatePlease to create content